i915 driver broken in -642 kernel

Issues related to hardware problems
Post Reply
gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

i915 driver broken in -642 kernel

Post by gerald_clark » 2016/05/27 20:19:23

I have an HP T5740 with an Atom N280 core with

Code: Select all

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 09)
"rhgb quiet" has been removed from the grub entries.
With 2.6.32-573.26.1.el6.i686 my HDMI1 connected monitor works perfectly, and xrandr shows both VGA1 and HDMI1 connected.
With the -642 kernel, the HDMI1 screen goes blank as soon as the kernel loads.
If I connect a VGA monitor to the VGA port, I can see the system boot. The HDMI1 monitor remains blank.
After starting X, xrandr show HDMI1 disconnected.

Has anyone else seen this?

anderson_thomas
Posts: 89
Joined: 2011/11/21 10:19:41

Re: i915 driver broken in -642 kernel

Post by anderson_thomas » 2016/06/27 12:03:00

Hi gerald_clark,

I have the same issue, see my (sorry I have seen your post too late) report:

Link: viewtopic.php?f=15&t=58316

Did you have a solution for that problem?

Thomas

anderson_thomas
Posts: 89
Joined: 2011/11/21 10:19:41

Re: i915 driver broken in -642 kernel

Post by anderson_thomas » 2016/06/27 12:33:37

Hi gerald_clark,

maybe a RedHat developer named Rob Clark can help solving the problem, because in the kernel-doc, lots of changes to i915 stuff, were made by him?

Does anybody have good connections to RedHat ;-)

Thank you!
Thomas.

Post Reply