Page 1 of 1

CentOS 6.7 and Intel Z270 Chipset

Posted: 2017/01/31 14:42:16
by CBall_WatcherP
Hi All,

First off, thank you for all of the hard work that you provide for the Linux community. We really appreciate your time and efforts. I work for a small surveillance company and the software that we use runs off of CentOS 6.7 GNOME (Kernel 4.4). We are currently in the midst of changing to the latest Z270 Intel chipset and I have a board we are using for testing. It's a Gigabyte Z270M-D3H and I cannot get it to boot through our CentOS image or the liveCD. Here are the full system specs.

Motherboard: Gigabyte Z270M-D3H
Ram: 2x4GB Kingston Hyper Fury X 2133MHz DDR4
CPU: Intel i7-6700
PSU: Cougar 700W Bronze Cert.
OS Drive: M.2 SSD

Our image will not load anything on boot. I see the mobo splash screen and then it goes blank (as usual) but then stays blank. We should have a company logo that loads and it does not. I have tried three different monitor outputs, from the mobo, and all results the same blank screen.

When I load the latest 6.7 liveCD, the image appears to begin loading (starts countdown to load) and then is just goes to a blank screen with a solid cursor in upper left. After about 2 min or so, I get the following error "BUG: soft lockup - CPU#0 stuck for 67s! [swapper:1]" and repeats.

I also tried this same system with a CentOS 7 liveCD and low and behold, all booted just fine. I know that there will be many saying to just upgrade to 7, but that is the problem. I can't upgrade to 7 due to developmental reasons. I guess my ultimate question is (in three parts),

1. Has their been successful testing on the Z270 chipset with CentOS 6.7?
2. If so, what exactly am I missing to get this to boot? (Not a true Linux expert but can figure enough out...)
3. If there has not been testing, will there be support for Z270 chipset with CentOS 6.7? How soon?

I really appreciate your time in reading this and any assistance in this matter would be greatly appreciated. Have a great day!!

Re: CentOS 6.7 and Intel Z270 Chipset

Posted: 2017/01/31 14:58:29
by TrevorH
6.7 is dead. 6.8 is current and 6.9 is in beta upstream. If you're running a 4.4 kernel then you're also not using a CentOS kernel either.

Re: CentOS 6.7 and Intel Z270 Chipset

Posted: 2017/02/01 00:48:32
by CBall_WatcherP
Thanks for the reply TrevorH. So you are pretty much saying there will be no support for Z270 chipset on 6.7(dead)?

Really sly of them to throw another kernel in there as well. Thanks, again!

Re: CentOS 6.7 and Intel Z270 Chipset

Posted: 2017/02/01 01:22:09
by TrevorH
Everything I've read about the z270 makes it sounds like a quite minor revision of the z170 so I would expect the standard CentOS kernel from 6.8 to work and if it doesn't then it's possible that 6.9 will. Current 6.8 kernel is 2.6.32-642.13.1.el6.x86_64.

Re: CentOS 6.7 and Intel Z270 Chipset

Posted: 2017/04/12 14:46:56
by cmshowers
I can confirm this problem. My relevant hardware is listed below. The 6.8 Live DVD outputs a stack trace while starting up (sorry, I can't scroll up to see the root cause). My installed image with kernel 2.6.32-642 gets the CPU stuck error as reported by the original poster and also outputs the following warning:
Detected CPU family 6 model 158
Warning: Intel CPU model - this hardware has not undergone testing by Red Hat and might not be certified.

However, the suggested fix of using 6.9 worked! I used the minimal iso image to do a system upgrade and was able to boot again (with kernel 2.6.32-696). Thanks for the support!

mobo: Giqabyte GA-H270N-WIFI
CPU: i5-7600K