HP Touchscreen (L2105tm) with CentOS 6.4

Issues related to hardware problems
Post Reply
jcouchman
Posts: 2
Joined: 2017/08/08 15:38:40

HP Touchscreen (L2105tm) with CentOS 6.4

Post by jcouchman » 2017/08/08 15:47:34

We have a piece of equipment which uses a computer running CentOS 6.4 to control it. We have this computer set up side by side with another controller and we switch back and forth between the 2 as we need to. There are times when, in order for the machine to run, we need a simple single click on one of the buttons on the screen. So we have to switch over, click the button, and switch back to the second computer to continue what we were doing.

So, we got the bright idea that it would be nice to have a touchscreen on the CentOS computer. It wouldn't be convenient to run the whole system using the touchscreen, but for those times when you need to just click the start button, or the reset button, it would be handy to have. We looked around and someone suggested that the touch screen capability may be in the OS by default and it would be plug and play, so we bought a used touch screen on ebay. We waited until we could get one on the cheap, so if this experiment fails we haven't sunk a ton of money into it. :)

We have the monitor now. An HP L2105tm. Plugged in the video and the USB. Video works fine. Touch screen doesn't. We have poked around in linux/unix over the years because almost all the machines from this vendor use some flavor of it in their controllers, but I'm by no means super familiar. Can someone provide some direction on how I would go about enabling the touch screen on this. The vendor doesn't support it, so they're no help, but I have access to do whatever I want - they just won't help me do it.

I have seen in my searches suggestions that I'll need a driver and a calibration utility, but I haven't found directions on how to accomplish that. Any help would be awesome!

User avatar
TrevorH
Forum Moderator
Posts: 23852
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: HP Touchscreen (L2105tm) with CentOS 6.4

Post by TrevorH » 2017/08/08 16:06:08

6.4 is unsupported and has been since the release of 6.5 nearly 4 years ago. There are numerous high severity security vulnerabilites in 6.4 that mean it should not be run. 6.9 is current and the only supported version.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

jcouchman
Posts: 2
Joined: 2017/08/08 15:38:40

Re: HP Touchscreen (L2105tm) with CentOS 6.4

Post by jcouchman » 2017/08/08 23:20:01

What version of OS they run is one thing I don't get a say in, unfortunately. It's not surprising that they're several versions behind, that's par for the course with these guys. 6.4 was probably the latest and greatest when they started development, and they are slow to change.

Post Reply