CentOS 6.9, GeForce 6600 & qtcreator/glx issues

Issues related to hardware problems
BlokeDownThePub
Posts: 9
Joined: 2009/11/12 15:00:04

CentOS 6.9, GeForce 6600 & qtcreator/glx issues

Postby BlokeDownThePub » 2017/10/30 18:13:01

On Centos 6.9.

Code: Select all

2.6.32-696.10.1.el6.x86_64 #1 SMP Tue Aug 22 18:51:35 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


I just replaced my GV-R587UD-1GD (Radeon HD 5870) which was very nice but hot, noisy, and overpowered for what I need with a smaller, cooler, quieter Nvidia GeForce 6600 silencer/256M.

Code: Select all

# lspci
...
02:00.0 VGA compatible controller: NVIDIA Corporation NV43 [GeForce 6600] (rev a2)
...


The machine booted in runlevel 3 fine but I couldn't get it to start in runlevel 5 and startx didn't work. Installed kmod-nvidia, didn't help so in a bit of a panic I installed Nvidia's driver from their site, filename was NVIDIA-Linux-x86_64-304.134.run

Now QT creator (3.0.1-3.el6 )doesn't work:

If I run it from the menu I briefly see a square frame pop up. From terminal I also see:

Code: Select all

# qtcreator
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile  0)
Aborted (core dumped)


Oddly (or perhaps not) designer & linguist seem to work OK. Installed via yum, from epel.

Any ideas (apart from using code::blocks or eclipse :cry: ) ? If I missed some relevant info let me know.

User avatar
jlehtone
Posts: 1887
Joined: 2007/12/11 08:17:33
Location: Finland

Re: CentOS 6.9, GeForce 6600 & qtcreator/glx issues

Postby jlehtone » 2017/11/04 11:20:24

BlokeDownThePub wrote:Installed kmod-nvidia, didn't help ...

The current kmod-nvidia?

Did you install first the 'nvidia-detect' and check with it whether it is kmod-nvidia or one of the legacy support versions that you need with that card?