lsscsi not show device path

Issues related to hardware problems
Post Reply
jack118
Posts: 3
Joined: 2018/03/17 09:16:15

lsscsi not show device path

Post by jack118 » 2018/03/17 09:26:46

Hi,

i have a centos 6.9 (final) 32bit

Linux server 2.6.32-696.23.1.el6.i686 #1 SMP Tue Mar 13 23:09:35 UTC 2018 i686 i686 i386 GNU/Linux

a pci x sata controller:

RAID bus controller: Adaptec AAC-RAID AAR-2610SA

the controller have 3 sata disk direct attach, i don't have configure hw raid:

# lsscsi
[0:0:0:0] disk ATA ST3160812AS E /dev/sda
[2:1:3:0] disk Hitachi HDS721010KLA330 GK0K -
[2:1:4:0] disk WDC WD10EADS-00L5B1 01.0 -
[2:1:5:0] disk WDC WD10EARS-00Y5B1 80.0 -

lsscsi not show the device path for the drive connected to the pci sata controller.

someone can help me ?

Thanks for the help

User avatar
avij
Forum Moderator
Posts: 2576
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: lsscsi not show device path

Post by avij » 2018/03/17 10:34:14

I would think this is normal. Search for 0:0:0:0 on http://sg.danny.cz/scsi/lsscsi.html

Edit: If you are referring to the missing /dev/sdX entries in the listing, try lsscsi --kname but note that this information may not be correct in certain situations. See man lsscsi and its Description section for information on how these are determined.

jack118
Posts: 3
Joined: 2018/03/17 09:16:15

Re: lsscsi not show device path

Post by jack118 » 2018/03/17 11:22:52

Thanks for your reply, i have try:

# sg_map
/dev/sg0 /dev/sda
/dev/sg1
/dev/sg2
/dev/sg3

# lsscsi -g
[0:0:0:0] disk ATA ST3160812AS E /dev/sda /dev/sg0
[2:1:3:0] disk Hitachi HDS721010KLA330 GK0K - /dev/sg1
[2:1:4:0] disk WDC WD10EADS-00L5B1 01.0 - /dev/sg2
[2:1:5:0] disk WDC WD10EARS-00Y5B1 80.0 - /dev/sg3

I can not understand why a path is not assigned for /dev/sg1 to /dev/sdx ecc..

User avatar
avij
Forum Moderator
Posts: 2576
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: lsscsi not show device path

Post by avij » 2018/03/17 11:49:48

Well, how about the lsscsi --kname that I suggested earlier?

And before proceeding further with suggestions: what are you actually trying to do, and how do the missing /dev/sdX entries in lsscsi's output affect this?

jack118
Posts: 3
Joined: 2018/03/17 09:16:15

Re: lsscsi not show device path

Post by jack118 » 2018/03/17 13:17:00

# lsscsi --kname
[0:0:0:0] disk ATA ST3160812AS E /dev/sda
[2:1:3:0] disk Hitachi HDS721010KLA330 GK0K -
[2:1:4:0] disk WDC WD10EADS-00L5B1 01.0 -
[2:1:5:0] disk WDC WD10EARS-00Y5B1 80.0 -

# lsscsi --kname -v
[0:0:0:0] disk ATA ST3160812AS E /dev/sda
dir: /sys/bus/scsi/devices/0:0:0:0 [/sys/devices/pci0000:00/0000:00:1f.2/host0/target0:0:0/0:0:0:0]
[2:1:3:0] disk Hitachi HDS721010KLA330 GK0K -
dir: /sys/bus/scsi/devices/2:1:3:0 [/sys/devices/pci0000:00/0000:00:1c.0/0000:02:01.0/host2/target2:1:3/2:1:3:0]
[2:1:4:0] disk WDC WD10EADS-00L5B1 01.0 -
dir: /sys/bus/scsi/devices/2:1:4:0 [/sys/devices/pci0000:00/0000:00:1c.0/0000:02:01.0/host2/target2:1:4/2:1:4:0]
[2:1:5:0] disk WDC WD10EARS-00Y5B1 80.0 -
dir: /sys/bus/scsi/devices/2:1:5:0 [/sys/devices/pci0000:00/0000:00:1c.0/0000:02:01.0/host2/target2:1:5/2:1:5:0]


And before proceeding further with suggestions: what are you actually trying to do, and how do the missing /dev/sdX entries in lsscsi's output affect this?
i need to rebuild an md raid5 array

Post Reply