NFS mounts as nobody:nobody

Issues related to configuring your network
bertalanimre
Posts: 134
Joined: 2015/06/02 13:04:03

NFS mounts as nobody:nobody

Postby bertalanimre » 2017/10/08 07:48:09

Hello All!

Could you help me please! I have 4 CentOS 6 servers. They have a few services like DRBD, Heartbeat, etc, but the issue is the NFS. A fifth server acts as NFS server and contains the folders I wish to mount on the other four. The /etc/exports file: (exportfs -a was done)
/shares/nfs 10.0.0.0/16(rw,sync,no_subtree_check,no_root_squash)

fstab on "clients":
10.0.X.XX:/shares/nfs /mnt/fs nfs hard,intr,retrans=2,rsize=32768,wsize=32768,noatime,timeo=600,nosuid 0 0

The issue is that only one server mounts the folders with correct permissions (root,www and other) But the remaining three mounts the folders with nobody:nobody and I have no idea how to fix this. nfsidmap -c was done as well, but didn't do the trick.

/etc/idmap.conf:
[General]
[Mapping]
Nobody-User = nobody
Nobody-Group = nobody
[Translations]
Method = nsswitch

Any idea I might have missed?

lightman47
Posts: 534
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: NFS mounts as nobody:nobody

Postby lightman47 » 2017/10/08 12:41:35

Off the top - are the UIDs and GIDS for all the users the same on all the machines? It's those IDs that are used, not necessarily the names.

I only ask because I've done it myself several years back.
:)

Whoever
Posts: 964
Joined: 2013/09/06 03:12:10

Re: NFS mounts as nobody:nobody

Postby Whoever » 2017/10/09 01:30:50

Is this when root tries to access the files? If so, look at the "no_root_squash" nfs export option.