Disabling SMBv1

Issues related to configuring your network
clum2
Posts: 6
Joined: 2017/11/03 14:47:48

Disabling SMBv1

Post by clum2 » 2017/11/06 14:21:45

I have recently disabled SMBv1 on my Win10 workstation and can no longer access samba shares on a CentOS 6.7 server running Samba 3.6.23-45.el6_9.

I reconfigured /etc/samba/smb.conf with the following:

min protocol = SMB2
max protocol = SMB3

But am still unable to see the shares from Windows. I've tried a mixture of server min protocol = SMB2 etc. but nothing seems to work. When I try to access the share, I get the following in /var/log/samba/

[2017/11/03 14:26:26.646887, 0] smbd/process.c:525(init_smb_request)
init_smb_request: invalid wct number 255 (size 178)

Searching for that error isn't providing me with any hints. Anyone got any ideas please?

User avatar
TrevorH
Forum Moderator
Posts: 23170
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Disabling SMBv1

Post by TrevorH » 2017/11/06 17:31:42

You'll almost certainly need to update to 6.9 which you should have done ages ago anyway. Your samba package is up to date but it probably has dependencies on the cifs kernel module which will only be in the latest kernel-2.6.32-696.13.2.el6.x86_64
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

clum2
Posts: 6
Joined: 2017/11/03 14:47:48

Re: Disabling SMBv1

Post by clum2 » 2017/11/07 11:26:22

Hi Trevor,
Thanks for your reply; I just checked properly there (/etc/redhat-release rather than what the VM host was telling me!) and it turns out I am on 6.9. What else could it potentially be?

Calum

User avatar
TrevorH
Forum Moderator
Posts: 23170
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Disabling SMBv1

Post by TrevorH » 2017/11/07 12:12:51

What does uname -a say?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

clum2
Posts: 6
Joined: 2017/11/03 14:47:48

Re: Disabling SMBv1

Post by clum2 » 2017/11/07 12:19:34

Linux servername 2.6.32-573.7.1.el6.x86_64 #1 SMP Tue Sep 22 22:00:00 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

User avatar
TrevorH
Forum Moderator
Posts: 23170
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Disabling SMBv1

Post by TrevorH » 2017/11/07 12:27:55

Looks like you need to reboot to get the newer kernel active. Yours is 2.6.32-573.7.1.el6.x86_64 from 2015 and the latest is 2.6.32-696.13.2.el6.x86_64.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

clum2
Posts: 6
Joined: 2017/11/03 14:47:48

Re: Disabling SMBv1

Post by clum2 » 2017/11/08 10:07:36

That's the new kernel active but still having problems; Windows 10 workstations with SMB1 removed can't log in whilst those with it still active can, despite the line

Code: Select all

min server protocol = SMB2
being added to /etc/samba/smb.conf

I'm totally confused!

User avatar
TrevorH
Forum Moderator
Posts: 23170
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Disabling SMBv1

Post by TrevorH » 2017/11/08 14:33:06

It's not something I've tried but I do know that you definitely needed to be on the latest of everything to even try as it's something that will only recently have been fixed. Hopefully someone else that's already done it can help.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

clum2
Posts: 6
Joined: 2017/11/03 14:47:48

Re: Disabling SMBv1

Post by clum2 » 2017/11/08 16:50:43

No worries; thanks for your help though.

Chirpychirps77
Posts: 18
Joined: 2018/01/12 01:36:06

Re: Disabling SMBv1

Post by Chirpychirps77 » 2018/01/13 20:55:27

clum2 wrote:That's the new kernel active but still having problems; Windows 10 workstations with SMB1 removed can't log in whilst those with it still active can, despite the line

Code: Select all

min server protocol = SMB2
being added to /etc/samba/smb.conf

I'm totally confused!
Hi,

I think this is exactly the problem. Your parameter is not correct in smb.conf, therefore smbv1 enabled Windows still access it.

Try simply 'protocol = SMB2' instead of the 'min server protocol = SMB2' (restarting samba afterwards). Just did it with Win10 VM to verify.

The 'min protocol' should also work; I think the 'server' part is where you went wrong.

Regards

Post Reply