iTop CMDB - CentOS 6.9

Issues related to configuring your network
Zim
Posts: 4
Joined: 2018/01/25 15:48:41

iTop CMDB - CentOS 6.9

Postby Zim » 2018/01/26 08:15:44

Hi everybody,

I don't know if I can post this topic here but I really need help.
I have to install iTop CMDB on centOS 6.9. I think my LAMP server is OK (apache ok, php ok and mysql too) and when I start my iTop configuration (unzip the itop repository + copy the "web" directory in the Apache's root directory) and I run my browser (Firefox) to start the CMDB configuration.

My browser doesn't display anything... just a white page... I don't know where is the problem...

Do you have any idea?

User avatar
TrevorH
Forum Moderator
Posts: 22584
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: iTop CMDB - CentOS 6.9

Postby TrevorH » 2018/01/26 10:40:05

Does running restorecon -RFv /var/www/html help?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Zim
Posts: 4
Joined: 2018/01/25 15:48:41

Re: iTop CMDB - CentOS 6.9

Postby Zim » 2018/01/26 15:01:53

it doesn't work...
I don't understand...

User avatar
TrevorH
Forum Moderator
Posts: 22584
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: iTop CMDB - CentOS 6.9

Postby TrevorH » 2018/01/26 15:54:09

So now you have to go read the logs to find out why not. Start in /var/log/httpd and go from there.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Zim
Posts: 4
Joined: 2018/01/25 15:48:41

Re: iTop CMDB - CentOS 6.9

Postby Zim » 2018/01/29 14:06:55

the log says "php fatal error: can't inherit abstract function countable::count () (previously declared in iDBObjectSetIterator) in /var/www/html/itop/core/dbobjectiterator.php"

stevemowbray
Posts: 366
Joined: 2012/06/26 14:20:47

Re: iTop CMDB - CentOS 6.9

Postby stevemowbray » 2018/01/29 14:24:55

My guess would be that the ancient version of PHP in CentOS 6 is not compatible with your application. Check its requirements.

User avatar
TrevorH
Forum Moderator
Posts: 22584
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: iTop CMDB - CentOS 6.9

Postby TrevorH » 2018/01/29 15:44:56

https://wiki.openitop.org/doku.php?id=2 ... tall:start says php 5.3.6 is the minimum required and CentOS 6 ships 5.3.3 by default though there are numerous backports applied to it which may mean that it is "good enough" - though apparently it's not.

CentOS 7 uses php 5.4.16 out of the box and would be one way to get there. You can also look at SCL packages or using a third party repo like IUS which ships newer php packages.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Zim
Posts: 4
Joined: 2018/01/25 15:48:41

Re: iTop CMDB - CentOS 6.9

Postby Zim » 2018/01/30 09:16:56

I change my OS... I use Debian Stretch. And it run very well.

Thanks you very much for your help!