Help! Broadcom wireless doesn't work after installing CentOS 6.

Issues related to configuring your network
Post Reply
sunswei
Posts: 3
Joined: 2011/07/22 03:52:17

Help! Broadcom wireless doesn't work after installing CentOS 6.

Post by sunswei » 2011/07/22 04:06:11

After installing the CentOS 6 on my DELL laptop, I follow the instruction showed at http://wiki.centos.org/HowTos/Laptops/Wireless/Broadcom to download hybrid-portsrc-x86_64-v5.10.91.9.3.tar.gz and build the wl.ko.

I though I built it successfully since I got
[code]
make: Entering directory `/usr/src/kernels/2.6.32-71.29.1.el6.x86_64'
LD /root/broadcom/driver/built-in.o
CC [M] /root/broadcom/driver/src/wl/sys/wl_linux.o
CC [M] /root/broadcom/driver/src/wl/sys/wl_iw.o
CC [M] /root/broadcom/driver/src/shared/linux_osl.o
LD [M] /root/broadcom/driver/wl.o
Building modules, stage 2.
MODPOST 1 modules WARNING: modpost: missing MODULE_LICENSE() in /root/broadcom/driver/wl.o see include/linux/module.h for more information
CC /root/broadcom/driver/wl.mod.o
LD [M] /root/broadcom/driver/wl.ko.unsigned
NO SIGN [M] /root/broadcom/driver/wl.ko make:
Leaving directory `/usr/src/kernels/2.6.32-71.29.1.el6.x86_64'
[/code]

But when I tried to do

insmod wl.ko

I got the [code]insmod: error inserting 'wl.ko': -1 Invalid module format[/code]

This error message is different with the one in the instruction. No matter how I followed the instruction, it always showed this message.

Could anyone here help me figure out what is wrong? I need to get my wireless card work.

Thanks for replying in advance.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Help! Broadcom wireless doesn't work after installing CentOS 6.

Post by pschaff » 2011/07/22 15:05:00

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

It seems ATrpms has kernel modules for EL6:
http://packages.atrpms.net/dist/el6/broadcom-wl/

Please read about [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14408&forum=47]Installing Software[/url] and [url=http://wiki.centos.org/AdditionalResources/Repositories]Repositories[/url], and note the warnings and advice about installing and configuring the [url=http://wiki.centos.org/PackageManagement/Yum/Priorities]yum priorities plugin[/url]. Non-core repos should have a higher numeric value, which is a lower priority. Lower is "better" as in golf scores.

The downside of the ATrpms packages is that they are kernel-specific. See also [url=http://elrepo.org/tiki/wl-kmod]wl-kmod at ELRepo[/url].

herrold
Posts: 100
Joined: 2005/03/19 22:14:28
Contact:

Help! Broadcom wireless doesn't work after installing CentOS

Post by herrold » 2011/07/22 16:02:26

A person also has to be running in the kernel to get the new module (so it can figure out where to put the new module), needs to run: 'make install', needs to blacklist some conflicting modules, and needs to re-run: depmod -a

I run this set of sources locally, on a laptop, and we should be able to work through this ..

-- Russ herrold

sunswei
Posts: 3
Joined: 2011/07/22 03:52:17

Re: Help! Broadcom wireless doesn't work after installing CentOS 6.

Post by sunswei » 2011/07/23 02:45:15

Thanks Phil,

I downloaded the rpm according to the version I checked under /usr/src/kernels/

then I run

yum --nopgpcheck localinstall broadcom*.rpm

then restart.

It works now. :-)

sunswei
Posts: 3
Joined: 2011/07/22 03:52:17

Re: Help! Broadcom wireless doesn't work after installing CentOS 6.

Post by sunswei » 2011/07/23 02:51:46

[quote]
herrold wrote:
A person also has to be running in the kernel to get the new module (so it can figure out where to put the new module), needs to run: 'make install', needs to blacklist some conflicting modules, and needs to re-run: depmod -a

I run this set of sources locally, on a laptop, and we should be able to work through this ..

-- Russ herrold[/quote]

Russ, I did not understand your "make install", did you mean to build a new *.ko and insmod as the instruction mentioned?

Maybe I missed some key points to build a *.ko.

Thanks.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Help! Broadcom wireless doesn't work after installing CentOS 6.

Post by pschaff » 2011/07/23 13:58:51

Apparently Russ is using a different method, but the [url=http://elrepo.org/tiki/wl-kmod]ELRepo method[/url] requires no explicit "make install" as that is handled in the package build process, and is the procedure I would follow in your shoes. It should produce a kABI-tracking module that will not require rebuilding with each new kernel within a compatible series. Generally this means within a major EL release cycle.

Post Reply

Return to “CentOS 6 - Networking Support”