Wireless not working on Dell XPS M1330

Issues related to configuring your network
Post Reply
scornsoftime
Posts: 1
Joined: 2011/07/26 23:05:01

Wireless not working on Dell XPS M1330

Post by scornsoftime » 2011/07/26 23:12:18

Hi,

First time trying CentOS 6 as my experiences with CentOS 5 weren't overly positive!

So, I'm using a Dell XPS M1330 and running the live CD - at the moment I don't have reliable ethernet connection, only wireless. So I needed to see if I could get the live CD up and running using wireless. As usual, I got the firmware not installed message so googled it and found the link below:

http://wiki.centos.org/HowTos/Laptops/Dell/XPS_M1330

I followed the instructions (pasted below for clarity)

Wired networking is provided by a Broadcom BCM5906M chipset that supports 10/100MBit only. This device is supported out of the box by the kernel tg3 driver.

The Dell XPS M1330 can ship with a number of wireless options although more recent samples appear to predominantly use the Intel 4965AGN chipset. The Intel 4965AGN chipset is supported by the iwlagn driver and mac80211 stack provided by the CentOS kernel. However, the firmware is missing but can be installed from RPMforge:

yum install iwl4965-firmware

The interface may be controlled using NetworkManager for connection to a WPA-PSK encrypted wireless LAN.

I get the following:

[centoslive@livecd ~]$ yum install iwl4965-firmware
Loaded plugins: fastestmirror, refresh-packagekit
You need to be root to perform this command.
[centoslive@livecd ~]$ sudo yum install iwl4965-firmware
Loaded plugins: fastestmirror, refresh-packagekit

base | 3.7 kB 00:00
base/primary_db | 4.2 MB 00:16
extras | 951 B 00:00

extras/primary | 203 B 00:00
updates | 3.5 kB 00:00
http://anorien.csc.warwick.ac.uk/mirrors/centos/6.0/updates/x86_64/repodata/9e02d8831e62ba5cdfc8cb07e531058cf17a08417cbe7b2c40131f922f4b45da-primary.sqlite.bz2: [Errno 12] Timeout on http://anorien.csc.warwick.ac.uk/mirrors/centos/6.0/updates/x86_64/repodata/9e02d8831e62ba5cdfc8cb07e531058cf17a08417cbe7b2c40131f922f4b45da-primary.sqlite.bz2: (28, '')

Trying other mirror.
http://mirrors.manchester.icecolo.com/centos/6.0/updates/x86_64/repodata/9e02d8831e62ba5cdfc8cb07e531058cf17a08417cbe7b2c40131f922f4b45da-primary.sqlite.bz2: [Errno 12] Timeout on http://mirrors.manchester.icecolo.com/centos/6.0/updates/x86_64/repodata/9e02d8831e62ba5cdfc8cb07e531058cf17a08417cbe7b2c40131f922f4b45da-primary.sqlite.bz2: (28, '')

Trying other mirror.
dupdates/primary_db 94% [============== ] 4.2 kB/s | 3.1 MB 00:43 ETAupdates/primary_db | 3.3 MB 04:21

Setting up Install Process
Package iwl4965-firmware-228.61.2.24-2.1.el6.noarch already installed and latest version
Nothing to do

Anyway able to offer any advice? Would like to use CentOS and get it working, but it does need to work with my wi-fi chipset! :D

Cheers all.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Wireless not working on Dell XPS M1330

Post by pschaff » 2011/07/30 19:01:58

Have you tried configuring the interface through the GUI nm-applet interface?

Post Reply

Return to “CentOS 6 - Networking Support”