mediawiki and dependency

Issues related to software problems.
Post Reply
dazdaz
Posts: 7
Joined: 2007/04/20 16:20:30

mediawiki and dependency

Post by dazdaz » 2007/05/05 15:24:41

Hi all, I would like to install mediawiki with full functionality.

mediawiki has a dependency (among many) with ImageMagick which depends upon hal and conflicts because that package requires a kernel version of less than 2.6.17.

Is there a quick way to resolve this with satisfying all of the dependencies.
I think I have yum configured correctly...

I would be grateful for any help and sorry for the long post.

# uname -r
2.6.19.1-RH220rc5


# yum install mediawiki
Repository rpmforge is listed more than once in the configuration
Setting up Install Process
Setting up repositories
rpmforge 100% |=========================| 1.1 kB 00:00
atrpms 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package mediawiki.i386 0:1.9.3-34.0.el5 set to be updated
--> Running transaction check
--> Processing Dependency: tetex-latex for package: mediawiki
--> Processing Dependency: ImageMagick for package: mediawiki
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package tetex-latex.i386 0:3.0-32.fc6 set to be updated
---> Package ImageMagick.i386 0:6.2.8.0-3.el5.4 set to be updated
--> Running transaction check
--> Processing Dependency: libwmflite-0.2.so.7 for package: ImageMagick
--> Processing Dependency: tetex = 3.0 for package: tetex-latex
--> Processing Dependency: librsvg-2.so.2 for package: ImageMagick
--> Processing Dependency: netpbm-progs for package: tetex-latex
--> Processing Dependency: libgs.so.8 for package: ImageMagick
--> Processing Dependency: liblcms.so.1 for package: ImageMagick
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lcms.i386 0:1.15-1.2.2 set to be updated
---> Package ghostscript.i386 0:8.15.2-9.1.el5 set to be updated
---> Package librsvg2.i386 0:2.16.1-1.el5 set to be updated
---> Package libwmf.i386 0:0.2.8.4-10.1 set to be updated
---> Package netpbm-progs.i386 0:10.35-6.fc6 set to be updated
---> Package tetex.i386 0:3.0-32.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: ghostscript-fonts for package: ghostscript
--> Processing Dependency: libgsf-1.so.114 for package: librsvg2
--> Processing Dependency: libORBit-2.so.0 for package: librsvg2
--> Processing Dependency: libgnomevfs-2.so.0 for package: librsvg2
--> Processing Dependency: libgconf-2.so.4 for package: librsvg2
--> Processing Dependency: urw-fonts >= 1.1 for package: ghostscript
--> Processing Dependency: libnetpbm.so.10 for package: netpbm-progs
--> Processing Dependency: gnome-vfs2 >= 1.9.16 for package: librsvg2
--> Processing Dependency: libgsf >= 1.6.0 for package: librsvg2
--> Processing Dependency: netpbm = 10.35-6.fc6 for package: netpbm-progs
--> Processing Dependency: ed for package: tetex
--> Processing Dependency: libcroco >= 0.6.1 for package: librsvg2
--> Processing Dependency: libcroco-0.6.so.3 for package: librsvg2
--> Processing Dependency: desktop-file-utils >= 0.9 for package: tetex
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libgsf.i386 0:1.14.1-6.1 set to be updated
---> Package GConf2.i386 0:2.14.0-9.el5 set to be updated
---> Package desktop-file-utils.i386 0:0.10-7 set to be updated
---> Package ghostscript-fonts.noarch 0:5.50-13.1.1 set to be updated
---> Package ORBit2.i386 0:2.14.3-4.el5 set to be updated
---> Package libcroco.i386 0:0.6.1-2.1 set to be updated
---> Package urw-fonts.noarch 0:2.3-6.1.1 set to be updated
---> Package ed.i386 0:0.2-38.2.2 set to be updated
---> Package netpbm.i386 0:10.35-6.fc6 set to be updated
---> Package gnome-vfs2.i386 0:2.16.2-4.el5 set to be updated
--> Running transaction check
--> Processing Dependency: chkfontpath for package: urw-fonts
--> Processing Dependency: libhal.so.1 for package: gnome-vfs2
--> Processing Dependency: libfam.so.0 for package: gnome-vfs2
--> Processing Dependency: mkfontscale for package: urw-fonts
--> Processing Dependency: libbonobo-2.so.0 for package: libgsf
--> Processing Dependency: libavahi-glib.so.1 for package: gnome-vfs2
--> Processing Dependency: libbonobo-activation.so.4 for package: libgsf
--> Processing Dependency: mkfontdir for package: urw-fonts
--> Processing Dependency: libdbus-glib-1.so.2 for package: gnome-vfs2
--> Processing Dependency: libdbus-1.so.3 for package: gnome-vfs2
--> Processing Dependency: libhal-storage.so.1 for package: gnome-vfs2
--> Processing Dependency: libavahi-client.so.3 for package: gnome-vfs2
--> Processing Dependency: gnome-mime-data >= 2.0.0-11 for package: gnome-vfs2
--> Processing Dependency: libavahi-common.so.3 for package: gnome-vfs2
--> Processing Dependency: gnome-mount >= 0.4 for package: gnome-vfs2
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xorg-x11-font-utils.i386 1:7.1-2 set to be updated
---> Package gnome-mime-data.i386 0:2.4.2-3.1 set to be updated
---> Package gnome-mount.i386 0:0.5-3.el5 set to be updated
---> Package libbonobo.i386 0:2.16.0-1.fc6 set to be updated
---> Package gamin.i386 0:0.1.7-8.el5 set to be updated
---> Package avahi-glib.i386 0:0.6.16-1.el5 set to be updated
---> Package hal.i386 0:0.5.8.1-19.el5 set to be updated
---> Package avahi.i386 0:0.6.16-1.el5 set to be updated
---> Package dbus.i386 0:1.0.0-6.el5 set to be updated
---> Package dbus-glib.i386 0:0.70-5 set to be updated
---> Package chkfontpath.i386 0:1.10.1-1.1 set to be updated
--> Running transaction check
--> Processing Dependency: libdaemon for package: avahi
--> Processing Dependency: libgnome-keyring.so.0 for package: gnome-mount
--> Processing Dependency: libbonoboui-2.so.0 for package: gnome-mount
--> Processing Dependency: pm-utils >= 0.10-1 for package: hal
--> Processing Dependency: libnotify.so.1 for package: gnome-mount
--> Processing Dependency: libgnomecanvas-2.so.0 for package: gnome-mount
--> Processing Conflict: hal conflicts kernel Processing Dependency: dmidecode >= 2.7 for package: hal
--> Processing Dependency: libgnome-2.so.0 for package: gnome-mount
--> Processing Dependency: cryptsetup-luks >= 1.0.1-2 for package: hal
--> Processing Dependency: xfs for package: chkfontpath
--> Processing Dependency: libdaemon.so.0 for package: avahi
--> Processing Dependency: libgnomeui-2.so.0 for package: gnome-mount
--> Processing Dependency: libvolume_id.so.0 for package: hal
--> Processing Dependency: dbus-python for package: avahi
--> Processing Dependency: libvolume_id >= 089-1 for package: hal
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libgnomeui.i386 0:2.16.0-5.el5 set to be updated
---> Package cryptsetup-luks.i386 0:1.0.3-2.2.el5 set to be updated
---> Package libbonoboui.i386 0:2.16.0-1.fc6 set to be updated
---> Package dbus-python.i386 0:0.70-7.el5 set to be updated
---> Package xorg-x11-xfs.i386 1:1.0.2-3.1 set to be updated
---> Package libgnome.i386 0:2.16.0-6.el5 set to be updated
---> Package libvolume_id.i386 0:095-14.5.el5 set to be updated
---> Package libnotify.i386 0:0.4.2-6.el5 set to be updated
---> Package pm-utils.i386 0:0.19-3.el5.centos.1 set to be updated
---> Package dmidecode.i386 1:2.7-1.28.2.el5 set to be updated
---> Package libgnomecanvas.i386 0:2.14.0-4.1 set to be updated
---> Package libdaemon.i386 0:0.10-5.el5 set to be updated
---> Package gnome-keyring.i386 0:0.6.0-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libglade-2.0.so.0 for package: libbonoboui
--> Processing Dependency: pciutils >= 2.2.1 for package: pm-utils
--> Processing Dependency: libaudiofile.so.0 for package: libgnome
--> Processing Dependency: libglade-2.0.so.0 for package: libgnomecanvas
--> Processing Conflict: hal conflicts kernel Processing Dependency: libglade-2.0.so.0 for package: libgnomeui
--> Processing Dependency: libglade2 >= 2.0.0 for package: libgnomeui
--> Processing Dependency: libglade2 >= 2.0.0 for package: libbonoboui
--> Processing Dependency: desktop-notification-daemon for package: libnotify
--> Processing Dependency: ttmkfdir for package: xorg-x11-xfs
--> Processing Dependency: esound >= 1:0.2.27 for package: libgnomeui
--> Processing Dependency: libesd.so.0 for package: libgnome
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ttmkfdir.i386 0:3.0.9-23.el5 set to be updated
---> Package libglade2.i386 0:2.6.0-2 set to be updated
---> Package esound.i386 1:0.2.36-3 set to be updated
---> Package pciutils.i386 0:2.2.3-4 set to be updated
---> Package notification-daemon.i386 0:0.3.5-8.el5 set to be updated
---> Package audiofile.i386 1:0.2.6-5 set to be updated
--> Running transaction check
--> Processing Conflict: hal conflicts kernel Processing Dependency: libwnck-1.so.18 for package: notification-daemon
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libwnck.i386 0:2.16.0-4.fc6 set to be updated
--> Running transaction check
--> Processing Conflict: hal conflicts kernel Processing Dependency: startup-notification >= 0.5 for package: libwnck
--> Processing Dependency: libstartup-notification-1.so.0 for package: libwnck
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package startup-notification.i386 0:0.8-4.1 set to be updated
--> Running transaction check
--> Processing Conflict: hal conflicts kernel Finished Dependency Resolution
Error: hal conflicts with kernel < 2.6.17
#


# yum info hal
Repository rpmforge is listed more than once in the configuration
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Available Packages
Name : hal
Arch : i386
Version: 0.5.8.1
Release: 19.el5
Size : 370 k
Repo : base
Summary: Hardware Abstraction Layer
Description:

HAL is daemon for collection and maintaining information from several
sources about the hardware on the system. It provides a live device
list through D-BUS.
:hammer:

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: mediawiki and dependency

Post by Lenard » 2007/05/05 16:16:56

Where did this come from?? Is it an installed by rpm kernel??? Or one you built???

# uname -r
2.6.19.1-RH220rc5

Check what kernel rpm packages do you have installed???

rpm -qa 'kernel*'

If this 2.6.19 kernel is built by you then go back to where you built it and do: make rpm
When done do something like;

cd /usr/src/redhat/RPMS/i686
rpm -ivh kernel-2.6.19.1*.rpm --justdb

dazdaz
Posts: 7
Joined: 2007/04/20 16:20:30

Re: mediawiki and dependency

Post by dazdaz » 2007/05/05 18:52:47

The kernel was pre-installed. It's a virtual CentOS 5 environment.

I can't find that 'custom kernel RPM' anywhere on my hosting providers mirror.

ok, so your suggesting that if I can find that RPM, that I insert this version of the kernel RPM into the RPM database but don't install the RPM, which is what the --justdb option does.

However, even if I could do that, then as I understand it, I would'nt be able to install the 'hal RPM' as it requires a lower kernel version, i.e. as indicated by this error message :

Error: hal conflicts with kernel < 2.6.17


# cd /usr/src/redhat/RPMS/i686
# ls -l
total 0

This confirms that the kernel is not recorded in the RPM database.

# rpm -qa 'kernel*'
kernel-headers-2.6.18-8.1.1.el5
kernel-2.6.9-34.EL


[quote]
Lenard wrote:
Where did this come from?? Is it an installed by rpm kernel??? Or one you built???

# uname -r
2.6.19.1-RH220rc5

Check what kernel rpm packages do you have installed???

rpm -qa 'kernel*'

If this 2.6.19 kernel is built by you then go back to where you built it and do: make rpm
When done do something like;

cd /usr/src/redhat/RPMS/i686
rpm -ivh kernel-2.6.19.1*.rpm --justdb[/quote]

dazdaz
Posts: 7
Joined: 2007/04/20 16:20:30

Re: mediawiki and dependency

Post by dazdaz » 2007/05/05 19:45:51

So I ran the following command below, and I had to use --nodeps option to RPM due to this message :
kernel < 2.6.12 conflicts with initscripts-8.45.14.EL-1.el5.centos.1.i386

# rpm -ivh --justdb kernel-2.6.18-8.1.3.el5.i686.rpm --nodeps
#

Now that I have a later kernel RPM installed, I still can't install mediawiki due to the same error from hal.

# rpm -qa | grep 'kernel*'
kernel-2.6.18-8.1.3.el5
kernel-headers-2.6.18-8.1.1.el5
kernel-2.6.9-34.EL

# yum install hal
...
...
...
Error: hal conflicts with kernel < 2.6.17

As I am running kernel 2.6.19.1-RH220rc5, and I have a later kernel information now in the RPM database I don't understand why hal is reporting that error message.

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: mediawiki and dependency

Post by Lenard » 2007/05/05 19:50:26

[quote]
However, even if I could do that, then as I understand it, I would'nt be able to install the 'hal RPM' as it requires a lower kernel version, i.e. as indicated by this error message :

Error: hal conflicts with kernel < 2.6.17
[/quote]

Your thinking is backwards, this means hal conflicts with a kernel older then 2.6.17 not newer. If you look below the problem is as far as the rpm database 'knows' you only have a 2.6.9 kernel installed, hence the error.

[quote]
# rpm -qa 'kernel*'
kernel-headers-2.6.18-8.1.1.el5
kernel-2.6.9-34.EL
[/quote]

This is strange, the installed kernel (kernel-2.6.9-34.EL) is from the RHEL4/CentOS4 series, the kernel-headers are for RHEL5/CentOS5. It is a good idea that both use the same version number, the kernel-headers package should be for the installed kernel. You really do not need the kernel-headers package installed since this server does not have the matching 2.6.18-8.1.1.el5 kernel installed.

Now with some understanding of what is not quite right on this system, you can resolve the hal issue by downloading the matching kernel form here and use the same command as I already suggested; rpm -ivh kernel-2.6.18-8.1.1.el5.i386.rpm --justdb

FYI: it really looks like somebody hacked (rather badly I might add) an old RHEL4/CentOS4 virtual server into an 'almost' RHEL5/CentOS5 virtual server with a custom kernel.

dazdaz
Posts: 7
Joined: 2007/04/20 16:20:30

Re: mediawiki and dependency

Post by dazdaz » 2007/05/05 21:17:20

I installed the matching kernel into the RPM database using the --justdb option, however the same error appears when I try to install mediawiki.

# rpm -qa 'kernel*'
kernel-2.6.18-8.1.1.el5
kernel-headers-2.6.18-8.1.1.el5
kernel-2.6.9-34.EL

# yum install mediawiki
...
...
--> Processing Conflict: hal conflicts kernel Finished Dependency Resolution
Error: hal conflicts with kernel < 2.6.17

I don't have much experience of virtualised environments, however this is a little odd. I have yet to do any research yet on why something like this would'nt work.

# lsmod
Opening /proc/modules: No such file or directory
[root@dazdaz build]# rpm -qf /sbin/lsmod
module-init-tools-3.3-0.pre3.1.16.0.1.el5

# grep proc /etc/fstab
none /proc proc defaults 0 0

Thanks

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: mediawiki and dependency

Post by Lenard » 2007/05/05 21:29:33

Try rpm -e kernel-2.6.9-34.EL --test

If you get no warning messages then remove the --test switch: rpm -e kernel-2.6.9-34.EL

dazdaz
Posts: 7
Joined: 2007/04/20 16:20:30

Re: mediawiki and dependency

Post by dazdaz » 2007/05/06 15:27:45

That worked ! Just wanted to say thanks for all of your help. mediawiki then installs over 55 RPM's.

Here is a summary of what I did, that worked for me.

rpm -e kernel-2.6.9-34.EL
rpm -ivh kernel-2.6.18-8.1.1.el5
yum install mediawiki

[quote]
Lenard wrote:
Try rpm -e kernel-2.6.9-34.EL --test

If you get no warning messages then remove the --test switch: rpm -e kernel-2.6.9-34.EL[/quote]

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: mediawiki and dependency

Post by Lenard » 2007/05/06 16:40:08

Good for you, glad to hear this and glad to help..........

Hopefully when you ran the yum install mediawiki all those updates and installs fixed other possible issues you might have had.

Post Reply

Return to “CentOS 5 - Software Support”