how can i build pppoe server on CentOS 5 ?

Issues related to software problems.
Post Reply
kevintan
Posts: 1
Joined: 2007/05/06 02:03:04

how can i build pppoe server on CentOS 5 ?

Post by kevintan » 2007/05/06 02:31:01

hello everyone !:)

I am newbie, i come from China.I am not speak English verywell ,So please don't matter
I try to build a pppoe server by CentOS 5,like this :

一.OS and software:
kernel:
2.6.18-8.el5
pack:
ppp-2.4.4-1.el5
rp-pppoe-3.5-32.1

# all are default

二.options:

[root@Routed-Server etc-]# grep 'pppoe' modprobe.conf
alias net-pf-24 pppoe

[root@Routed-Server etc-ppp]# cat options
lock
plugin rp-pppoe.so
noipdefault
debug
crtscts
asyncmap 0
nodetach
lcp-echo-interval 30
lcp-echo-failure 4
idle 600
noipx
nobsdcomp
nodeflate
nopcomp
ms-dns 202.96.128.68
ms-dns 202.96.134.133
logfile /var/log/ppp/pppd.log

[root@Routed-Server etc-ppp]# cat pppoe-server-options
# PPP options for the PPPoE server
# LIC: GPL
login
require-pap
lcp-echo-interval 10
lcp-echo-failure 2

[root@Routed-Server etc-ppp]# cat pap-secrets
# Secrets for authentication using PAP
# client server secret IP addresses
"TMeng" * "88888888" *

[root@Routed-Server etc-ppp]# grep 'TMeng' /etc/passwd
TMeng:503:503::/home/TMeng:/bin/bash


三.start pppoe-server
/usr/sbin/pppoe-server -I eth0 -L 192.168.3.254 -R 192.168.3.10

四.check process
[root@sggd ~]# ps aux |grep 'pppoe'
root 3060 0.0 0.0 2564 192 ? S 08:05 0:00 /usr/sbin/pppoe-server -I eth0 -L 192.168.3.254 -R 192.168.3.10
root 4012 0.0 0.2 5644 640 pts/4 R+ 13:44 0:00 grep pppoe

五.view log:
tail -f /var/log/messages

Apr 27 09:53:23 Tmhinkpad pppoe-server[3190]: Session 1 created for client 00:15:f2:9c:72:a7 (192.168.3.10) on eth0 using Service-Name ''
Apr 27 09:53:24 Tmhinkpad pppd[3190]: Plugin rp-pppoe.so loaded.
Apr 27 09:53:24 Tmhinkpad kernel: CSLIP: code copyright 1989 Regents of the University of California
Apr 27 09:53:24 Tmhinkpad pppd[3190]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.4
Apr 27 09:53:24 Tmhinkpad kernel: PPP generic driver version 2.4.2
Apr 27 09:53:24 Tmhinkpad pppd[3190]: pppd 2.4.4 started by root, uid 0
Apr 27 09:53:24 Tmhinkpad pppd[3190]: Using interface ppp0
Apr 27 09:53:24 Tmhinkpad pppd[3190]: Connect: ppp0 /dev/pts/0
Apr 27 09:53:55 Tmhinkpad pppd[3190]: LCP: timeout sending Config-Requests
Apr 27 09:53:55 Tmhinkpad pppd[3190]: Connection terminated.
Apr 27 09:53:55 Tmhinkpad pppd[3190]: Modem hangup
Apr 27 09:54:00 Tmhinkpad pppd[3190]: Exit.

# view debug:

using channel 1
Using interface ppp0
Connect: ppp0 /dev/pts/0
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfReq id=0x1 ]
rcvd [LCP ConfReq id=0x2 ]
sent [LCP ConfRej id=0x2 ]
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfReq id=0x1 ]
rcvd [LCP ConfReq id=0x4 ]
sent [LCP ConfRej id=0x4 ]
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfReq id=0x1 ]
rcvd [LCP ConfReq id=0x6 ]
sent [LCP ConfRej id=0x6 ]
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfReq id=0x1 ]
rcvd [LCP ConfReq id=0x8 ]
sent [LCP ConfRej id=0x8 ]
LCP: timeout sending Config-Requests
Connection terminated.
Modem hangup
Waiting for 1 child processes...
script /usr/sbin/pppoe -n -I eth0 -e 1:00:15:f2:9c:72:a7 -S '', pid 3142
sending SIGTERM to process 3142

# check process when pppoe client (winxp) login
[root@sggd ~]# ps aux |grep 'pppoe'
root 3060 0.0 0.0 2564 192 ? S 08:05 0:00 /usr/sbin/pppoe-server -I eth0 -L 192.168.3.254 -R 192.168.3.10
root 3755 0.0 0.5 3496 1372 ? Ss 08:06 0:00 pppd pty /usr/sbin/pppoe -n -I eth0 -e 1:00:14:78:84:15:f2 -S '' file /etc/ppp/pppoe-server-options 192.168.3.254:192.168.3.10 nodetach noaccomp nobsdcomp nodeflate nopcomp novj novjccomp default-asyncmap
root 4012 0.0 0.2 5644 640 pts/4 R+ 13:44 0:00 grep pppoe

六.Note !!
The same configuration are work well on CentOS 4.4

[root@Routed-Server friends]# uname -r
2.6.9-42.EL
[root@Routed-Server friends]# rpm -qa|grep 'ppp'
ppp-2.4.2-6.4.RHEL4
rp-pppoe-3.5-22

verify the work well pppoe server (CentOS4.4) debug messages :

# tail -f /var/log/pppd.log
using channel 8
Using interface ppp1
Connect: ppp1 /dev/pts/0
rcvd [LCP ConfReq id=0x0 ]
sent [LCP ConfReq id=0x1 ]
sent [LCP ConfRej id=0x0 ]
rcvd [LCP ConfAck id=0x1 ]
rcvd [LCP ConfReq id=0x1 ]
sent [LCP ConfAck id=0x1 ]
sent [LCP EchoReq id=0x0 magic=0x150ef117]
rcvd [LCP code=0xc id=0x2 4a 00 50 ef 4d 53 52 41 53 56 35 2e 31 30]
sent [LCP CodeRej id=0x2 0c 02 00 12 4a 00 50 ef 4d 53 52 41 53 56 35 2e 31 30]
rcvd [LCP code=0xc id=0x3 4a 00 50 ef 4d 53 52 41 53 2d 30 2d 4b 2d 36 34 46 36 39 42 42 42 41 46 46 37 34]
sent [LCP CodeRej id=0x3 0c 03 00 1f 4a 00 50 ef 4d 53 52 41 53 2d 30 2d 4b 2d 36 34 46 36 39 42 42 42 41 46 46 37 34]
rcvd [PAP AuthReq id=0x3 user="sgz001" password=]
user sgz001 logged in

# at Centos 4.4 ,is can be works
**********************************************************************************************************


I think some bady can fix this problem, Thanks very much!!

Post Reply

Return to “CentOS 5 - Software Support”