Errors during make

Issues related to software problems.
Post Reply
pnunn
Posts: 6
Joined: 2007/03/16 05:42:18
Contact:

Errors during make

Post by pnunn » 2007/05/17 05:52:04

Folks,

I'm trying to compile some drivers that worked fine in CentOS 4, but Im struggling os 5.

When I do make (as either root or user) I get part way through the make and it failes with

[quote]Will use ///usr/src/kernels/2.6.18-8.1.3.el5-i686/include for header files.
No kernel support for SMP detected.
In file included from :1:
///usr/src/kernels/2.6.18-8.1.3.el5-i686/include/linux/config.h:6:2: warning: #warning Including config.h is deprecated.
///usr/src/kernels/2.6.18-8.1.3.el5-i686/include/linux/config.h:9:2: error: #error including kernel header in userspace; use the glibc headers instead!
Kernel support for mod-versions detected.
Kernel support for IP version 6 detected.
No kernel support for IP version 6 modules detected.

The file ///usr/src/kernels/2.6.18-8.1.3.el5-i686/include/linux/version.h is missing
LiS needs thie file in order to build properly.
This may be an indication that there is no kernel
source on this machine, or only partial kernel source.[/quote]

Now... uname -a returns

[quote]Linux WMHS-A.xacom.com.au 2.6.18-8.1.3.el5 #1 SMP Mon Apr 30 19:55:44 EDT 2007 i686 i686 i386 GNU/Linux[/quote]

and locate version.h returns

[quote]/usr/include/gnu/libc-version.h
/usr/include/linux/version.h
/usr/include/linux/dvb/version.h
/usr/src/kernels/2.6.18-8.1.3.el5-i686/include/config/localversion.h
/usr/src/kernels/2.6.18-8.1.3.el5-i686/include/config/isdn/diversion.h
/usr/src/kernels/2.6.18-8.1.3.el5-i686/include/linux/version.h
/usr/src/kernels/2.6.18-8.1.3.el5-i686/include/linux/dvb/version.h
/usr/src/kernels/2.6.18-8.1.3.el5-i686/include/pcmcia/version.h
/usr/src/kernels/2.6.18-8.1.3.el5-i686/include/sound/version.h
/usr/src/kernels/2.6.18-8.1.3.el5-i686/include/xen/interface/version.h
/usr/src/kernels/2.6.18-8.el5-i686/include/config/localversion.h
/usr/src/kernels/2.6.18-8.el5-i686/include/config/isdn/diversion.h
/usr/src/kernels/2.6.18-8.el5-i686/include/linux/version.h
/usr/src/kernels/2.6.18-8.el5-i686/include/linux/dvb/version.h
/usr/src/kernels/2.6.18-8.el5-i686/include/pcmcia/version.h
/usr/src/kernels/2.6.18-8.el5-i686/include/sound/version.h
/usr/src/kernels/2.6.18-8.el5-i686/include/xen/interface/version.h[/quote]

which, as you can see does have the file in question. I can open it in vi quite happily. Any ideas what mingh be going on here? I initially thought permissions, but I can't even get it to run as root.

Ta

Peter

User avatar
toracat
Forum Moderator
Posts: 7386
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Errors during make

Post by toracat » 2007/05/18 16:49:54

This link may help you:

http://nntp.hk/web/post.php?group=ibm.software.commserver.linux&xref=155&server=news.software.ibm.com

Akemi

Post Reply

Return to “CentOS 5 - Software Support”