mime.types error doing a rpmbuild on courier

Issues related to software problems.
Locked
wulfpack74
Posts: 85
Joined: 2008/03/17 22:26:54

mime.types error doing a rpmbuild on courier

Post by wulfpack74 » 2008/04/11 12:05:42

I am trying to run:
sudo rpmbuild -ta courier-0.59.0.tar.bz2

but getting this error:

error: Failed build dependencies:
/etc/mime.types is needed by courier-0.59.0-1.i386

ls -l /etc/mime.types
-rw-r--r-- 1 root root 13099 Apr 10 16:44 /etc/mime.types



any suggestions? Ive search far and wide and can not find anyone else who has had this problem with courier.

2.6.18-53.1.14.el5

wulfpack74
Posts: 85
Joined: 2008/03/17 22:26:54

Re: mime.types error doing a rpmbuild on courier

Post by wulfpack74 » 2008/04/11 19:27:05

rpm -q --whatprovides /etc/mime.types
mailcap-2.1.23-1.fc6



installed this.

mailcap-2.1.23-1.fc6


But now I am getting another error


rpmbuild -ta courier-0.59.0.tar.bz2
error: Failed to rename /usr/src/redhat/SPECS/rpm-spec.2sk9ps to /usr/src/redhat/SPECS/rpm-spec.2sk9ps: Permission denied: No such file or directory


ls -l /usr/src/redhat/SPECS
total 52
-rw------- 1 root root 9111 Apr 10 14:35 courier-authlib.spec
-rw------- 1 root root 9438 Apr 10 14:47 courier-imap.spec
-rw------- 1 root root 28332 Apr 11 16:15 courier.spec
-rw-r--r-- 1 root root 0 Apr 11 16:21 rpm-spec.mSqdpY
-rw------- 1 root root 0 Apr 11 08:51 tar: *.spec: Not found in archive



How do I get past this error?

Abdul
Posts: 6
Joined: 2014/07/01 06:26:41

Re: mime.types error doing a rpmbuild on courier

Post by Abdul » 2014/07/01 07:18:37

Hi,

I am working as a Linux Support in Web Server environment. I am looking for Courier Email Server configuration and testing.

*) I have installed the following RPM packages in RHEL6.4 x86x64 Linux box.

courier-imapd-0.63.0-1.fc11.i586
gdbm-1.8.0-37.8.x86_64.rpm
courier-authlib-0.63.0-1.fc11.i586.rpm
courier-authlib-devel-0.63.0-1.fc11.i586.rpm


But i am unable to start the courier-imapd service.

Error : Failed:- Authentication courier-imapd


I think i installed the wrong packages with dependencies. Can any one please tell me the working package with procedure for RHEL 6.4 (64bit).

User avatar
TrevorH
Forum Moderator
Posts: 26942
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: mime.types error doing a rpmbuild on courier

Post by TrevorH » 2014/07/01 07:43:56

Don't install random packages from the internet. Fedora 11 is not CentOS 6 and the packages for that will not work.

Do you need courier specifically? CentOS 6 supplies dovecot packages for imap.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
TrevorH
Forum Moderator
Posts: 26942
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: mime.types error doing a rpmbuild on courier

Post by TrevorH » 2014/07/01 11:32:16

Actually I just noticed that you hijacked a 6 year old thread about CentOS 5 with unrelated info about courier packages on CentOS 6 and have also started your own thread in the correct forum so I'm going to lock this thread to prevent further updates.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Locked

Return to “CentOS 5 - Software Support”