Cannot add CAC Reader to "Security Devices" in Firefox

Issues related to software problems.
thegreatturtle
Posts: 32
Joined: 2008/11/07 05:05:26
Location: Guam
Contact:

Cannot add CAC Reader to "Security Devices" in Firefox

Postby thegreatturtle » 2008/11/17 09:55:23

I have a SCR 3340 Expresscard. It is Linux compatible. I installed the Linux drivers for it.

HP Pavilion dv6755us
CentOS 5.2

I followed this link too the letter. http://ubuntuforums.org/showthread.php? ... =cac+reade

When I try to add the CAC reader as a "Security Device" as one of the final steps, I get an "unable to add module" error.

Can anyone help me figure this out?


pcsc_scan
PC/SC device scanner
V 1.4.14 (c) 2001-2008, Ludovic Rousseau
Compiled with PC/SC lite version: 1.4.4
Scanning present readers
0: Expresscard SmartCard Reader (21220732702252) 00 00

Mon Nov 17 19:55:34 2008
Reader 0: Expresscard SmartCard Reader (21220732702252) 00 00
Card state: Card removed,

Thanks in advance.

ksudbury
Posts: 20
Joined: 2008/07/29 11:23:00
Contact:

Cannot add CAC Reader to "Security Devices" in Firefox

Postby ksudbury » 2008/11/17 12:45:53

Hi,

I don't know a great deal about this, however I have done some research as I am in a good mood this morning...

For a start have you given firefox the correct path? on my fedora box it's /usr/lib/libcoolkeypk11.so or if you are x86_64 /usr/lib64/libcoolkeypk11.so you might want to do a search on your box for "libcool" with locate or a simular tool just to confirm these paths.

That guide you posted was for Ubuntu that does not support CAC out of the box your centos 5 box should, (just checked my centos 5 box and pcsd etc is installed), anyway it seems to be detecting your card ok.



Also have you seen this DoD Configuration firefox addon https://addons.mozilla.org/en-US/firefox/addon/3182 ? Maybe of some use to you found it while searching for your problem on google.



Let me know how you get on,

Keith

thegreatturtle
Posts: 32
Joined: 2008/11/07 05:05:26
Location: Guam
Contact:

Re: [SOLVED] Cannot add CAC Reader to "Security Devices" in Firefox

Postby thegreatturtle » 2008/11/17 19:32:44

Keith,

[color=FF0000]YOU FREAKIN ROCK!!!![/color]


I didn't know about the other coolkey.so file. Your right, that other config must be for Ubuntu only. I pointed towards the /usr/lib/coolkey file and it added my reader immediately. I was able to log into my DOD email and everything.

Oh, I did add the DOD add-on prior to this post.

My wife is rolling her eyes because I'm jumping around. haha

Thanx a ton.

Dan

bertalanimre
Posts: 134
Joined: 2015/06/02 13:04:03

Re: Cannot add CAC Reader to

Postby bertalanimre » 2017/03/30 13:46:59

OK, and what now since firefox have disabled that plugin and I'm unable to use my CAC card to log in to a DoD website with it?

I've installed libcoolkey and the devel too. I've got:
/usr/lib64/pkcs11/libcoolkeypk11.so
/usr/lib64/libcoolkeypk11.so


BUT, when I want to add the module, firefox is saying "adding the module have failed" (or similar)

User avatar
TrevorH
Forum Moderator
Posts: 21174
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Cannot add CAC Reader to

Postby TrevorH » 2017/03/30 14:24:02

Are you using CentOS 5? Please don't post to 8 year old threads with your own problems, raise a new topic in the right forum for your release and if necessary please include a link to any older threads you think might be relevant.

Topic locked.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke