Vim will not compile with python support

Issues related to software problems.
User avatar
Super Jamie
Posts: 310
Joined: 2014/01/10 23:44:51

Re: Vim will not compile with python support

Post by Super Jamie » 2014/05/10 07:52:23

Oh. You've replaced the system's Python 2.4 with Python 3.

This is very likely to cause problems later on. Any system tools written in Python (notably the package manager, yum) are written for 2.4 and not 3.

If yum ever updates python packages (if yum still works), keep in mind what you did may break.

I mentioned earlier:
Note that EL5 comes with Python 2.4.3. If you wish to build in a later version of Python, this thread on Stack Overflow covers the process. It looks like you'll need to have a working install of the intended Python version, located in a different path than the original Python which is pre-installed on the system (don't try to overwrite the system's Python with a later version, things will get messy).
Best of luck!

cdaringe
Posts: 8
Joined: 2014/03/11 08:18:02

Re: Vim will not compile with python support

Post by cdaringe » 2014/05/10 16:15:46

Perhaps that's a little cavalier of me to post, but indeed it did not purge 2.4. 3 installed to usr/local/xxx and 2.4 is still alive and well.

cdaringe
Posts: 8
Joined: 2014/03/11 08:18:02

Re: Vim will not compile with python support

Post by cdaringe » 2014/08/13 08:44:13

Hi all:

I'd like to revive this topic. As noted before, I got my vim to compile with py3.3. Indeed I desire 2.7.x support now, and revisited this thread. Despite trying many alternatives (a) vim .configure still references /usr/bin/python (2.4) even when config path is pointing to 2.7 and it happens even when (b) virtualenv is on and active for 2.7. This is evidenced by vim's configure script output where it states the path. One gentleman hinted that if http://stackoverflow.com/questions/5872 ... -of-python the virtualenv was created by 2.4, then Vim will somehow navigate it's way back to the 2.4 binary on configure/compile. I've attempted his proposed workaround, however, vim doesn't like executing any python by that point, and yields a 'E264: Python: Error initialising I/O objects' and seg faults. Seg fault?! Terrible news.

I do have 2.x support in vim, it's just the wrong version. It would be really great if there was truly a way to force the config script to look @the virtualenv, and not take the 2.4 bin. Perhaps a manual edit of the configure script is in order. Your thoughts?

Post Reply

Return to “CentOS 5 - Software Support”