LibXML LibXSLT perl dependency problem

Issues related to software problems.
Post Reply
sternci
Posts: 1
Joined: 2014/06/30 15:21:34

LibXML LibXSLT perl dependency problem

Post by sternci » 2014/06/30 16:19:25

I have not seen a solution to this problem after extensive searching:

My current config:
[root@juisebox SprintDemo]# rpm -q centos-release
centos-release-5-10.el5.centos

[root@juisebox SprintDemo]# yum list installed | grep -i libxml
libxml2.x86_64 2.6.26-2.1.21.el5_9.3 installed
libxml2-devel.x86_64 2.6.26-2.1.21.el5_9.3 installed
libxml2-python.x86_64 2.6.26-2.1.21.el5_9.3 installed
perl-XML-LibXML.x86_64 1.58-6 installed
perl-XML-LibXML-Common.x86_64 0.13-8.2.2 installed

[root@juisebox SprintDemo]# yum list installed | grep -i libxslt
libxslt.x86_64 1.1.17-4.el5_8.3 installed
libxslt-devel.x86_64 1.1.17-4.el5_8.3 installed
libxslt-python.x86_64 1.1.17-4.el5_8.3 installed
perl-XML-LibXSLT.x86_64 1.63-2.el5.rf installed

My code fragment:
#!/usr/bin/perl

use lib qw(./);
use warnings;
use diagnostics;
use strict;
use MBHNetworkAppsCS;
use Data::Dumper;
use XML::LibXML;
use XML::LibXSLT;

BEGIN { $ENV{PERL_NET_HTTPS_SSL_SOCKET_CLASS} = "Net::SSL";
$ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;
}

My problem:
[root@juisebox SprintDemo]# ./GetServiceDefinition.pl

MBH Network Apps REST API Script Execution
Uncaught exception from user code:
This version of XML::LibXSLT requires XML::LibXML 1.6 (ABI 1), which is incompatible with currently installed XML::LibXML 2.0014 (ABI 2). Please upgrade XML::LibXSLT, XML::LibXML, or both! at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/XML/LibXML.pm line 50.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/XML/LibXSLT.pm line 7.
Compilation failed in require at ./GetServiceDefinition.pl line 10.
BEGIN failed--compilation aborted at ./GetServiceDefinition.pl line 10.
at ./GetServiceDefinition.pl line 10

So, I seem to have a garden variety dependency problem, but I am unable to downgrade libxml, or upgrade the perl LibXML from epel. Suggestions?

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: LibXML LibXSLT perl dependency problem

Post by gerald_clark » 2014/06/30 16:42:00

You are attempting to mix libraries from repoforge with libraries from epel.
Chose one, remove the libraries installed from the other.
Repoforge is not being updated, so I would stick with epel.

Post Reply

Return to “CentOS 5 - Software Support”