Page 1 of 1

Fail2Ban update to 0.8.13-2.el5 fails

Posted: 2014/08/16 11:33:58
by rwap
I am running Centos 5.10

I have today received a yum update of Fail2Ban to 0.8.13-2.el5

However, when restarting there is an error reported in

/usr/share/fail2ban/server/filterpyinotify.py

The error relates to the line:

Code: Select all

		except Exception as e:
This requires an update to Python (currently at 2.4.3-56.el5 in the distribution).

For now, I have amended the line to read:

Code: Select all

		except Exception, e:
But obviously the better answer would be to push the upgrade to Python which implements this syntax

Re: Fail2Ban update to 0.8.13-2.el5 fails

Posted: 2014/08/16 11:45:14
by TrevorH
An upgrade to python is not going to happen so this is a bug in fail2ban. The system python is used by little things like yum so updating it is not possible. You need to report this upstream as a bug in fail2ban.

Re: Fail2Ban update to 0.8.13-2.el5 fails

Posted: 2014/08/16 11:51:59
by rwap
That's a shame, as it works on another server I have running Centos 6.

Fail2Ban is already well past v0.8.13 - it is currently at 0.9.1, so they are not going to fix an issue in 0.8.13...

So who do you report this to?

Re: Fail2Ban update to 0.8.13-2.el5 fails

Posted: 2014/08/16 13:25:34
by gerald_clark
You report it to the people you installed it from ( epel? ).

Re: Fail2Ban update to 0.8.13-2.el5 fails

Posted: 2014/08/16 13:32:27
by rwap
Hmm yes, it was installed from EPEL - sorry - thought it was a standard Centos package...