Upgrade to Bluez to 4.x or 5.x on CentOS 5.9

Issues related to software problems.
Post Reply
Nlotf
Posts: 2
Joined: 2014/08/26 17:29:06

Upgrade to Bluez to 4.x or 5.x on CentOS 5.9

Post by Nlotf » 2014/08/26 17:37:39

Good day,

First off this is my first post on CentOS forum and I think a declaration is required that I am quite a newbie when it comes to CentOS.

I am running CentOS 5.9 ( I intend to upgrade to 5.10 soon but since I am using that box to run Elastix 2.4 which only run on RHEL 5 I guess I am stuck and can not upgrade to CentOS 6.

The current bluez utilities for CentOS 5 is 3.7 which is quite old and gives me a headache when it comes to bluetooth audio (maybe something to do with bluetooth audio buffer. Anyways, I searched high and low for a way to be able to upgrade to Bluez to 4.x or even 5.x versions that would surely be a great leap for me on CentOS 5.9. Is that even possible !! I guess I am missing a fundamental point here.

Thank you in advance.

User avatar
TrevorH
Forum Moderator
Posts: 26910
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Upgrade to Bluez to 4.x or 5.x on CentOS 5.9

Post by TrevorH » 2014/08/31 00:13:55

Yes, you're missing a fundamental point about the way that CentOS (and RHEL) works. The versions of packages are pretty much fixed at the initial release of the product and do not change for the 10 year lifespan of the distro. If you need newer packages then you need to update to the newer major version. I am pretty sure that Elastix have a CentOS 6 based version that you can use.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 5 - Software Support”