Samba Issue

Issues related to software problems.
Post Reply
weiqi2
Posts: 3
Joined: 2015/01/16 03:56:46

Samba Issue

Post by weiqi2 » 2015/01/16 04:12:21

Hi,

My system is using centos 4.5 and window xp. Previously samba 3.0.33 is working fine here.
I have a issue now. I would be upgrading my windows clients to windows 7. Centos - windows 7 sharing does not seem to work with samba 3.0.33. Which samba version supports Windows 7 ? Do i need to upgrade my Centos 4.5 ? or just install the samba with the latest version 4 ?

Thanks.

User avatar
TrevorH
Forum Moderator
Posts: 26884
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Samba Issue

Post by TrevorH » 2015/01/16 12:54:01

Do you really mean CentOS 4.5? CentOS 4 has been end of life for nearly 3 years and you should be migrating off it to a supported release ASAP as there have been no security fixes for 3 years. In addition, 4.5 is not the most recent 4.x version anyway so you have an additional missing couple of years of fixes to worry about!
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

weiqi2
Posts: 3
Joined: 2015/01/16 03:56:46

Re: Samba Issue

Post by weiqi2 » 2015/01/22 07:26:22

Yes, i understand. This is a COTS product and we cant change the OS.

Any advise on whether CENTOS 4.5 can work with the latest version of SAMBA that supports Windows 7 ?

User avatar
TrevorH
Forum Moderator
Posts: 26884
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Samba Issue

Post by TrevorH » 2015/01/22 09:07:34

I very much doubt it. I do not know what a "COTS product" is but CentOS 4 is unsupported, has a full 3 years worth of missing security fixes and 4.5 is from 2007 so is missing a further 5 years of fixes. It's a timebomb waiting to explode and at the very least should be locked down in its own area and monitored for intrusions. If you keep any sensitive data on the machine then you really need to secure it properly - probably by disconnecting the network cable.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

weiqi2
Posts: 3
Joined: 2015/01/16 03:56:46

Re: Samba Issue

Post by weiqi2 » 2015/01/22 09:10:20

Noted with thanks.
COTS refer to commercial off-the-shelf products.
So which means to say, unless I upgrade my CENTOS to a new version, I would not be able to do SAMBA sharing with WIN 7.

Post Reply

Return to “CentOS 5 - Software Support”