update issue in 5.11 for popt

Issues related to software problems.
Post Reply
volumetricsteve
Posts: 13
Joined: 2014/11/29 20:44:48

update issue in 5.11 for popt

Post by volumetricsteve » 2015/02/16 13:45:27

I'm trying to apply the normal batch of regular updates, and popt is giving me fits. If I try to install popt I get the following:

Code: Select all

[root@new-host-3 ~]# yum install popt
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * centosplus: centos.corenetworks.net
 * contrib: mirror-centos.hostingswift.com
 * extras: mirrors.tripadvisor.com
 * fasttrack: mirrors.tripadvisor.com
 * rpmforge: mirror.nexcess.net
 * rpmforge-extras: mirror.nexcess.net
 * rpmforge-testing: mirror.nexcess.net
 * updates: ftp.osuosl.org
Setting up Install Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: popt = 1.10.2.3-36.el5_11 for package: rpm
--> Processing Dependency: popt = 1.10.2.3-36.el5_11 for package: rpm-python
--> Processing Dependency: popt = 1.10.2.3-36.el5_11 for package: rpm-libs
---> Package popt.i386 0:1.14-1.el5.test set to be updated
--> Finished Dependency Resolution
rpm-python-4.4.2.3-36.el5_11.i386 from installed has depsolving problems
  --> Missing Dependency: popt = 1.10.2.3-36.el5_11 is needed by package rpm-python-4.4.2.3-36.el5_11.i386 (installed)
rpm-4.4.2.3-36.el5_11.i386 from installed has depsolving problems
  --> Missing Dependency: popt = 1.10.2.3-36.el5_11 is needed by package rpm-4.4.2.3-36.el5_11.i386 (installed)
rpm-libs-4.4.2.3-36.el5_11.i386 from installed has depsolving problems
  --> Missing Dependency: popt = 1.10.2.3-36.el5_11 is needed by package rpm-libs-4.4.2.3-36.el5_11.i386 (installed)
Error: Missing Dependency: popt = 1.10.2.3-36.el5_11 is needed by package rpm-libs-4.4.2.3-36.el5_11.i386 (installed)
Error: Missing Dependency: popt = 1.10.2.3-36.el5_11 is needed by package rpm-4.4.2.3-36.el5_11.i386 (installed)
Error: Missing Dependency: popt = 1.10.2.3-36.el5_11 is needed by package rpm-python-4.4.2.3-36.el5_11.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
That makes it sound to me like either popt isn't installed, or the wrong version is installed. So I wanted to see what was going on:

Code: Select all

[root@new-host-3 ~]# yum --showduplicates list popt | expand
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * centosplus: centos.corenetworks.net
 * contrib: ftpmirror.your.org
 * extras: mirrors.tripadvisor.com
 * fasttrack: mirrors.tripadvisor.com
 * rpmforge: mirror.nexcess.net
 * rpmforge-extras: mirror.nexcess.net
 * rpmforge-testing: mirror.nexcess.net
 * updates: mirror.lug.udel.edu
Installed Packages
popt.i386                  1.10.2.3-36.el5_11                   installed       
Available Packages
popt.i386                  1.10.2.3-31.el5                      C5.9-base       
popt.i386                  1.10.2.3-32.el5_9                    C5.9-updates    
popt.i386                  1.10.2.3-36.el5_11                   updates         
popt.i386                  1.11-1.el5.test                      rpmforge-testing
popt.i386                  1.12-1.el5.test                      rpmforge-testing
popt.i386                  1.13-1.el5.test                      rpmforge-testing
popt.i386                  1.14-1.el5.test                      rpmforge-testing
So it looks like it is installed, and looks like it's also the right version. What am I missing here?

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: update issue in 5.11 for popt

Post by gerald_clark » 2015/02/16 13:53:16

---> Package popt.i386 0:1.14-1.el5.test set to be updated
--> Finished Dependency Resolution
rpm-python-4.4.2.3-36.el5_11.i386 from installed has depsolving problems
--> Missing Dependency: popt = 1.10.2.3-36.el5_11 is needed by package rpm-python-4.4.2.3-36.el5_11.i386 (installed)

It is trying to replace the correct version with one from rpmforge-testing, but the current version is needed by python.
Disable rmpforge-testing.

User avatar
TrevorH
Forum Moderator
Posts: 26915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: update issue in 5.11 for popt

Post by TrevorH » 2015/02/16 13:55:57

You've been rpmforged ;-(

Incidentally you seem to have disabled your CentOS 'base' repo and enabled the C5.9 base and updates ones.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

volumetricsteve
Posts: 13
Joined: 2014/11/29 20:44:48

Re: update issue in 5.11 for popt

Post by volumetricsteve » 2015/02/16 14:02:55

Ahhhh!!!! I bet I did that when I was trying my damnedest to get either PrBoom or Yamagi Quake 2 to compile and it needed some weird thing. That fixed it, it was the fact I disabled centos-base(which I had done amidst troubleshooting the issue) and had rpmforge-testing on. Why's rpmforge gotta do me like this?

Also, thanks for the help, I wouldn't have thought to point the finger at rpmforge

User avatar
TrevorH
Forum Moderator
Posts: 26915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: update issue in 5.11 for popt

Post by TrevorH » 2015/02/16 15:07:10

You should review your use of rpmforge altogether, most packages from there have seen zero updates for 2 or 3 years and the whole repo has gone pretty much unmaintained. There are packages in it that have unfixed security vulnerabilities.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

volumetricsteve
Posts: 13
Joined: 2014/11/29 20:44:48

Re: update issue in 5.11 for popt

Post by volumetricsteve » 2015/02/16 23:47:53

Noted. I honestly can't remember why I thought I needed it in the first place, but I'm sure it was to compile some goofy engine, probably PrBoom. I have it disabled for now and updates are coming through cleanly. Thanks again for the help.

Post Reply

Return to “CentOS 5 - Software Support”