mod_wsgi on CentOS 5.4 built with python2.7

Issues related to software problems.
Post Reply
mmulqu
Posts: 11
Joined: 2013/02/05 16:09:31

mod_wsgi on CentOS 5.4 built with python2.7

Post by mmulqu » 2015/04/14 21:52:55

One of my users has need for mod_wsgi on a server running CentOS 5.4. I installed the package from RPMForge which he has found to be inadequate for his needs. He needs for it to have been built against Python-2.7 instead of 2.4. My first issue with this is that I just don't want to do it because every time I've tried to mess with Python installations on Redhat-ish systems, things go wrong. My second issue with this is that I've been upgrading all of our servers to CentOS 7.0 and this server is next on my list. So, I'll be able to install this package, built against Python-2.7, for him as soon as the upgrade is complete. I'm perfectly fine just going back to the user and telling him to wait for a couple of weeks. Also, I'm not even sure if this is possible because I've never heard of anyone wanting to do something like this.

Is this even possible?

If possible, is it recommended?

If recommended, is it easy enough to justify going through the process to have this working for only two weeks before the server is upgraded?

If it's easy enough, would someone please let me know how to do it?

Thanks!

Matt

mmulqu
Posts: 11
Joined: 2013/02/05 16:09:31

Re: mod_wsgi on CentOS 5.4 built with python2.7

Post by mmulqu » 2015/04/14 22:08:14

The further I look into this, the more it looks like this needs to wait for the CentOS 7 upgrade. I've posed this question to the mod_wsgi mailing list as well.

User avatar
TrevorH
Forum Moderator
Posts: 26864
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: mod_wsgi on CentOS 5.4 built with python2.7

Post by TrevorH » 2015/04/14 22:42:47

First off, you really don't want to be running 5.4. That's ancient and has umpty-zillion bugs in it some of them both severe and security related. Yuo should yum update to 5.11 ASAP.

You cannot update the system python on RHEL/CentOS systems without breaking all the system tools like yum. You can however use parallel installable copies like those provided by the IUS Community repo. These install in parallel with the system python and you invoke them with a different executable - e.g. /usr/bin/python27

We no longer recommend use of rpmforge as there have been almost no updates to the packages in there for about 3 years now. This means that many have unfixed security vulnerabilities.

However in EPEL I can see the following packages:

Code: Select all

mod_wsgi.x86_64                                           3.5-1.el5                                               epel
python26-mod_wsgi.x86_64                                  3.5-1.el5                                               epel
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 5 - Software Support”