CentOS 5.3 does not detect ethernet card on HP proliant G9

Issues related to configuring your network
xtdz32
Posts: 10
Joined: 2016/03/18 12:49:10

CentOS 5.3 does not detect ethernet card on HP proliant G9

Postby xtdz32 » 2016/03/18 12:54:08

I have a HP Proliant G9 server, i installed CentOS 5.3 because of the precise specific purpose it was needed for, 5.3 was the best option, and fater installation, it does not detect eth0,
ports displayed are sit0 and lo

Please help urgent

User avatar
TrevorH
Forum Moderator
Posts: 21206
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 5.3 does not detect ethernet card on HP proliant

Postby TrevorH » 2016/03/18 13:22:52

Do not use CentOS 5.3. It came out in early 2009 so has now accumulated more than 7 *years* worth of security vulnerabilities and bugs. You should be installing CentOS 5.11 which is the ONLY supported 5.x version that exists. Even then it has only a little over 1 year of life left in it before it reaches EOL and you will need to reinstall with a newer version: 6, 7 or perhaps even 8 by then.

A ProLiant Gen 9 server post-dates CentOS 5.3 by about 6.5 years so expecting hardware support to be present in an operating system for hardware that didn't even exist when it was built is a bit optimistic. I am unsure if even the 5.11 version will support the hardware since, again, a gen 9 server is probably newer than the o/s itself.

If you need convincing that you should not use 5.3, please go to http://rhn.redhat.com/errata/rhel-server-errata.html and read all the patches marked Critical and Important that have come out since January 2009 when 5.3 was released. If you use 5.3 then you will have all of those security vulnerabilities. Don't do it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

xtdz32
Posts: 10
Joined: 2016/03/18 12:49:10

Re: CentOS 5.3 does not detect ethernet card on HP proliant

Postby xtdz32 » 2016/03/22 09:44:35

Thank you trevor.

I tried to install CentOS 6.2, and the OS does not detect the raid array, does not detect the drives to proceed with installation.
How do i solve this problem ?

xtdz32
Posts: 10
Joined: 2016/03/18 12:49:10

Re: CentOS 5.3 does not detect ethernet card on HP proliant

Postby xtdz32 » 2016/03/22 09:47:36

TrevorH wrote:Do not use CentOS 5.3. It came out in early 2009 so has now accumulated more than 7 *years* worth of security vulnerabilities and bugs. You should be installing CentOS 5.11 which is the ONLY supported 5.x version that exists. Even then it has only a little over 1 year of life left in it before it reaches EOL and you will need to reinstall with a newer version: 6, 7 or perhaps even 8 by then.

A ProLiant Gen 9 server post-dates CentOS 5.3 by about 6.5 years so expecting hardware support to be present in an operating system for hardware that didn't even exist when it was built is a bit optimistic. I am unsure if even the 5.11 version will support the hardware since, again, a gen 9 server is probably newer than the o/s itself.

If you need convincing that you should not use 5.3, please go to http://rhn.redhat.com/errata/rhel-server-errata.html and read all the patches marked Critical and Important that have come out since January 2009 when 5.3 was released. If you use 5.3 then you will have all of those security vulnerabilities. Don't do it.




I Just tried to install CentOS 6.2, and the OS does not detect the HDD so i can procedd with installation. I already configured the raid array from the HP utilities . And i still can not detect it.

User avatar
TrevorH
Forum Moderator
Posts: 21206
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 5.3 does not detect ethernet card on HP proliant

Postby TrevorH » 2016/03/22 10:29:11

I have replied to your 6.2 topic. Try using a version that's been released in the last 5 years and still lin support. That would be 6.7, 7.2 or 5.11 although 5.x only has 1 year of support lifetime left.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

xtdz32
Posts: 10
Joined: 2016/03/18 12:49:10

Re: CentOS 5.3 does not detect ethernet card on HP proliant

Postby xtdz32 » 2016/03/22 17:21:05

Worked well.. Thanx a whole lot . Will just check and hope my app is compatible