Need to upgrade to openssh 6.2 +

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
User avatar
AlanBartlett
Forum Moderator
Posts: 9323
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: Need to upgrade to openssh 6.2 +

Post by AlanBartlett » 2013/10/08 22:34:18

You mention [i]CentOS 5.8[/i]. Usage of that version is deprecated, as 5.9 is the current release and 5.10 is on the way . . .

Please clarify the situation by showing the output produced by --

[code]
[b]rpm -qa \*release\* | sort[/b]
[/code]

[quote]
. . . the PCI "people" are now asking me to prove via a web link that the version of openssh installed is up to date for the CentOS version installed, CentOS release 5.8 (Final).
[/quote]
As has previously been written, [u][b]the numpties will [i]have[/i] to read the openssh package change log[/b][/u] . . . there is no web link.

optikaa
Posts: 92
Joined: 2009/03/26 19:24:37

Re: Need to upgrade to openssh 6.2 +

Post by optikaa » 2013/10/09 10:46:18

#rpm -qa \*release\* | sort
atomic-release-1.0-10.el5.art
centos-release-5-8.el5.centos
centos-release-notes-5.8-0
rpmforge-release-0.5.2-2.el5.rf

I don't think I have upgraded centos before, is it a fairly safe thing to do in terms of compatibility with the currently installed packages?

User avatar
AlanBartlett
Forum Moderator
Posts: 9323
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: Need to upgrade to openssh 6.2 +

Post by AlanBartlett » 2013/10/09 11:28:10

There is no support for any version of [i]CentOS[/i] other than the current release.

Therefore you are presently running an unsupported release which is missing the latest security patches and bug fixes.

I now see that you also have a problematic repository configured. Usage of the [i]Atomic[/i] repository is something to avoid as it will over-write core [i]CentOS[/i] packages.

To update your system, first please read the [url=http://wiki.centos.org/Manuals/ReleaseNotes/CentOS5.9]CentOS 5.9 Release Notes[/url], then perform the update, ensuring that the [i]Atomic[/i] repository is disabled --

[code]
[b]yum --disablerepo \* --enablerepo base,updates update[/b]
[/code]

optikaa
Posts: 92
Joined: 2009/03/26 19:24:37

Re: Need to upgrade to openssh 6.2 +

Post by optikaa » 2013/10/09 15:59:20

I got this error...

Transaction Check Error:
file /etc/my.cnf from install of mysql-5.0.95-5.el5_9.i386 conflicts with file from package mysql-libs-5.0.56-1.el5.centos.i386

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Need to upgrade to openssh 6.2 +

Post by gerald_clark » 2013/10/09 16:59:17

mysql-libs is not a CentOS supplied package.

optikaa
Posts: 92
Joined: 2009/03/26 19:24:37

Re: Need to upgrade to openssh 6.2 +

Post by optikaa » 2013/10/09 17:04:39

I think this relates to the Atomic repo and probably a previous PCI compliance issue.

Can I safely remove this and get the normal mysql back without affecting the sites databases?

optikaa
Posts: 92
Joined: 2009/03/26 19:24:37

Re: Need to upgrade to openssh 6.2 +

Post by optikaa » 2013/10/09 17:32:14

update I removed all mysql packages but cannot install php-mysql

--> Missing Dependency: php-common = 5.1.6-40.el5_9 is needed by package php-mysql-5.1.6-40.el5_9.i386 (updates)

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Need to upgrade to openssh 6.2 +

Post by gerald_clark » 2013/10/09 17:47:40

We can't help you without the full output from the yum update command.
You probably have an issue with atomic and conflicting php versions.
Atomic is never the answer to PCI compliance issues.

optikaa
Posts: 92
Joined: 2009/03/26 19:24:37

Re: Need to upgrade to openssh 6.2 +

Post by optikaa » 2013/10/09 17:49:15

It's ok I've removed and re-installed php - lesson learned about Atomic, hopefully I can update centos this time.

optikaa
Posts: 92
Joined: 2009/03/26 19:24:37

Re: Need to upgrade to openssh 6.2 +

Post by optikaa » 2013/10/09 17:59:35

So I have upgrade ok now but openssh remains on 5.2:

rpm -qa \*release\* | sort
centos-release-5-9.el5.centos.1
centos-release-notes-5.9-0
rpmforge-release-0.5.2-2.el5.rf

Post Reply

Return to “CentOS 5 - Server Support”