BIND responds but won't resolve

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
Mayniyak
Posts: 1
Joined: 2014/02/17 19:35:49

BIND responds but won't resolve

Post by Mayniyak » 2014/02/17 20:30:21

I'm putting together a local web development server for myself, which I want to run a standard LAMP stack plus SFTP and BIND. The purpose of BIND here is to create multiple hostnames for the server, with each hostname loading up a different virtual host in apache.

Now... BIND is responding to nslookup requests perfectly fine, but when trying to actually use any other service (PING, HTTP, SFTP, etc) the clients time out. Yet these services do work when accessing them directly via IP address. This happens on both the local console as well as any remote clients (Linux,Win,OSX).

Any help figuring this out is much appreciated.

/etc/named.conf

Code: Select all

options
{
	// Put files that named is allowed to write in the data/ directory:
	directory 		"/var/named";
	dump-file 		"data/cache_dump.db";
        statistics-file 	"data/named_stats.txt";
        memstatistics-file 	"data/named_mem_stats.txt";
	listen-on port 53	{ any; };
	//listen-on-v6 port 53	{ any; };
	allow-query		{ any; };
	allow-query-cache	{ none; };
	recursion no;
	dnssec-enable no;
	dnssec-validation no;
	dnssec-lookaside no;
	notify no;
};

logging
{
        category default { null; };
};

zone "." IN {
        type hint;
        file "named.ca";
};

zone "devl.home" { 
	type master;
	file "devl.home";
}	;
/var/named/devl.home

Code: Select all

;
; BIND data file for zone devl.home
;
$TTL 4h
@		IN	SOA	ns1.devl.home.	root.devl.home.	(
		0		; Serial
		8H		; Refresh
		2H		; Retry
		8H		; Expire
		1H	)	; Minimum
; The main record for this server
		IN	NS	ns1.devl.home.
ns1		IN	A	192.168.10.71
; Other records, used for Apache virtual hosts
lamp		IN	CNAME	ns1
phpmyadmin	IN	CNAME	ns1

Post Reply

Return to “CentOS 5 - Server Support”