Page 1 of 1

[SOLVED] DNS won't start !!!!!

Posted: 2014/02/25 21:19:23
by hannibal007
hi everybody !!

i want to install a DNS server with the domain name: 3omda.net and the server hostname : 3imed.esprit so here are the configuration files:

named.conf configuration file: 3omda.net.db

http://imgur.com/qHtQu0O

direct zone configuration file

Image
http://imgur.com/JjEKV39

inverse-zone configuration file : 0.168.192.db

Image
http://imgur.com/oyNNTRX

problem message when starting named service

Image
http://imgur.com/elYF4mE

the problem seems on the inverse-zone resolution configuration file : no current owner name

even i runned the command: named-checkzone 0.168.192.db pathfile ; it returns the same error: no current owner name

check zone command :
Image
http://imgur.com/ihRPuOB

does anybody have solution ???

Re: DNS won't start !!!!!

Posted: 2014/02/25 21:22:32
by gerald_clark
The machine name comes before the domain name, not after.
Use your domain registrar's name servers.

Re: DNS won't start !!!!!

Posted: 2014/02/25 21:25:41
by hannibal007
gerald_clark wrote:The machine name comes before the domain name, not after.
Use your domain registrar's name servers.
yes it is configurated like that: machine name + domain name
3imed.esprit.3omda.net.

Re: DNS won't start !!!!!

Posted: 2014/02/25 23:44:52
by hannibal007
yep resolved !!!!!!!!!! the whitespaces in reverse zone file configuration are the cause !!!!!!!!!!!!!!!!! i've delete it all and then yepppppppppppppppppppaaaaa :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D