python-policyd-spf on CentOS 5

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
Dudydoo
Posts: 2
Joined: 2014/07/14 13:41:02

python-policyd-spf on CentOS 5

Post by Dudydoo » 2014/07/14 13:55:37

Hi,

Has anyone managed to get python-policyd-spf to work on CentOS 5? is it even possible?

I downloaded and installed the latest source release which requires python-2.6 or higher (Centos 5 uses 2.4), so I then tried pypolicy-spf 1.0 which is suppose to work on python-2.4 AFAIK and I get an error when running /usr/bin/policyd-spf about a syntax error.

Code: Select all

File "/usr/bin/policyd-spf", line 225
    except TypeError as x:
                      ^
SyntaxError: invalid syntax
My python knowlege is limited, but as far as I can tell this means the python interpreter does not understand the 'as' keyword.

I have a VPS running CentOS 5 postfix as a secondary MX. It works flawlessly on C6.

Any help appreciated.

User avatar
TrevorH
Forum Moderator
Posts: 26970
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: python-policyd-spf on CentOS 5

Post by TrevorH » 2014/07/14 14:01:36

You can find python26 packages in EPEL which install alongside the system python 2.4. Should then just be a matter of changing your script to invoke /usr/bin/python26...
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Dudydoo
Posts: 2
Joined: 2014/07/14 13:41:02

Re: python-policyd-spf on CentOS 5

Post by Dudydoo » 2014/07/14 14:06:43

Hi Trevor,

Thank you for you fast reply.

I didn't know I can install 2.6 alongside 2.4 and didn't want to bork the rest of my system. I will have a look at that.

Thanks again.

Post Reply

Return to “CentOS 5 - Server Support”