Install PHP dbase

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
ScyDark
Posts: 2
Joined: 2016/04/27 12:53:09

Install PHP dbase

Postby ScyDark » 2016/04/27 12:58:56

Hello,

I have a server running CentOS 5.8 with PHP 5.3 and need to install dbase on it.
I tried "yum install php-dbase", here is the result:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.weezel.co.uk
* extras: centos.weezel.co.uk
* updates: centos.mirrors.ovh.net
Excluding Packages in global exclude list
Finished
Setting up Install Process
Package php-dbase is obsoleted by php-common, trying to install php-common-5.1.6-45.el5_11.i386 instead
Resolving Dependencies
--> Running transaction check
---> Package php-common.i386 0:5.1.6-45.el5_11 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-26.el5_11.i386 from installed has depsolving problems
--> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


I checked the phpinfo, no dbase in the configure:
'./configure' '--build=i386-redhat-linux-gnu' '--host=i386-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--with-kerberos' '--enable-ucd-snmp-hack' '--enable-shmop' '--enable-calendar' '--without-sqlite' '--with-libxml-dir=/usr' '--enable-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--without-sqlite3' '--disable-phar' '--disable-fileinfo' '--disable-json' '--without-pspell' '--disable-wddx' '--without-curl' '--disable-posix' '--disable-sysvmsg' '--disable-sysvshm' '--disable-sysvsem'


dbase is not even in the modules list (/usr/lib/php/modules):
drwxr-xr-x 3 root root 4096 déc 29 10:40 .
drwxr-xr-x 4 root root 4096 oct 31 2014 ..
-rwxr-xr-x 1 root root 61476 oct 31 2014 curl.so
-rwxr-xr-x 1 root root 150132 oct 31 2014 dom.so
-rwxr-xr-x 1 root root 1842560 oct 31 2014 fileinfo.so
-rwxr-xr-x 1 root root 310704 oct 31 2014 gd.so
-rwxr-xr-x 1 root root 86424 oct 31 2014 imap.so
-rw-r--r-- 1 root root 932012 jun 9 2014 ioncube_loader_lin_5.1.so
-rw-r--r-- 1 root root 923820 jun 9 2014 ioncube_loader_lin_5.2.so
-rw-r--r-- 1 root root 894904 jun 9 2014 ioncube_loader_lin_5.3.so
-rw-r--r-- 1 root root 1042868 jun 9 2014 ioncube_loader_lin_5.4.so
-rw-r--r-- 1 root root 1071244 jun 9 2014 ioncube_loader_lin_5.5.so
-rwxr-xr-x 1 root root 31928 oct 31 2014 json.so
-rwxr-xr-x 1 root root 2023344 oct 31 2014 mbstring.so
-rwxr-xr-x 1 root root 113324 oct 31 2014 mysqli.so
-rwxr-xr-x 1 root root 43032 oct 31 2014 mysql.so
-rwxr-xr-x 1 root root 24460 oct 31 2014 pdo_mysql.so
-rwxr-xr-x 1 root root 90076 oct 31 2014 pdo.so
-rwxr-xr-x 1 root root 20172 oct 31 2014 pdo_sqlite.so
-rwxr-xr-x 1 root root 257060 oct 31 2014 phar.so
-rwxr-xr-x 1 root root 13068 fév 22 2012 phpcups.so
-rwxr-xr-x 1 root root 327692 oct 31 2014 soap.so
-rwxr-xr-x 1 root root 368612 jui 8 2011 sqlite.so
drwxr-xr-x 2 root root 4096 déc 30 16:57 sw-engine
-rwxr-xr-x 1 root root 31224 oct 31 2014 wddx.so
-rwxr-xr-x 1 root root 24348 oct 31 2014 xmlreader.so
-rwxr-xr-x 1 root root 37692 oct 31 2014 xmlwriter.so
-rwxr-xr-x 1 root root 27832 oct 31 2014 xsl.so
-rwxr-xr-x 1 root root 76388 oct 31 2014 zip.so


Could someone please help me with this?

Thank you.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Install PHP dbase

Postby gerald_clark » 2016/04/27 14:27:06

1. Don't run CentOS 5.8. It is old, unsupported, and has many exploits. Run "yum update" to update to the current 5.11.
CentOS 5 is less than year away from End Of Life. You should start looking at building a new server with CentOS 6 or 7.
2. If you want to use PHP53 you need to remove the CentOS supplied PHP or there will be conflicts.

User avatar
avij
Forum Moderator
Posts: 2137
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Install PHP dbase

Postby avij » 2016/04/27 14:30:42

php53 is actually a CentOS-provided package, it's alright.

The error message says php-dbase is obsoleted by php-common, so there's a chance that your php53-common (that you have installed) has the required support. Have you actually tried any of the dBase functions to see if they are available?

ScyDark
Posts: 2
Joined: 2016/04/27 12:53:09

Re: Install PHP dbase

Postby ScyDark » 2016/04/27 14:35:35

Hello,

Thank you for your answers. I will try to update CentOS to version 5.11. In the next weeks or months, I will buy a new server and transfer everything to it.

I tried the dBase functions (that was the first thing I tried), but it did not work:
PHP Fatal error: Call to undefined function dbase_create()

User avatar
avij
Forum Moderator
Posts: 2137
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Install PHP dbase

Postby avij » 2016/04/27 14:58:14

Right, it seems the dBase functionality was dropped from php53, and I don't see it in any more recent versions either. This page says "This extension has been moved to the PECL repository and is no longer bundled with PHP as of PHP 5.3.0."

Are you sure you actually need this support? Do you, for example, have .dbf files that you would need to import? If not, you would be better off using some other database (see the linked page above).

User avatar
remirepo
Posts: 249
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: Install PHP dbase

Postby remirepo » 2016/04/27 15:23:31

I still have package of php-pecl-dbase.... but only for php 5.4 or greater (so in "remi-safe" for CentOS-7), sorry, nothing for php/php53 versions in C5.

P.S. yes this extension is deprecated and not maintained, but make sense to have it to retrieve data from some old app, and help moving to a recent / decent database format.
Remi's Repository - Forum - Blog