Help CentOS 5 Upgrade PHP to PHP 5.2.x

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Luffy_Senpai
Posts: 2
Joined: 2016/05/11 18:18:13

Help CentOS 5 Upgrade PHP to PHP 5.2.x

Postby Luffy_Senpai » 2016/05/11 18:56:56

I tried this link but it doesn't work

Code: Select all

https://wiki.centos.org/HowTos/PHP_5.1_To_5.2


when i tried to yup updates i get this error.
Image

here is my centrOS-testing.repo.

Code: Select all

# CentOS-Testing:
# !!!! CAUTION !!!!
# This repository is a proving grounds for packages on their way to CentOSPlus and CentOS Extras.
# They may or may not replace core CentOS packages, and are not guaranteed to function properly.
# These packages build and install, but are waiting for feedback from testers as to
# functionality and stability. Packages in this repository will come and go during the
# development period, so it should not be left enabled or used on production systems without due
# consideration.
[c5-testing]
name=CentOS-5 Testing
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs=php*

User avatar
remirepo
Posts: 250
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: Help CentOS 5 Upgrade PHP to PHP 5.2.x

Postby remirepo » 2016/05/12 08:55:21

PHP 5.3.3 is available in standard repo (php53* packages)

No other repo provides 5.2 which is EOL an unmaintained.
Remi's Repository - Forum - Blog

User avatar
TrevorH
Forum Moderator
Posts: 21018
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Help CentOS 5 Upgrade PHP to PHP 5.2.x

Postby TrevorH » 2016/05/12 10:07:42

The php 5.2 packages were deliberately withdrawn from the CentOS "testing" repo because they were too old and had too many security vulnerabilities built-in! You should not use 5.2 under any circumstances.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Luffy_Senpai
Posts: 2
Joined: 2016/05/11 18:18:13

Re: Help CentOS 5 Upgrade PHP to PHP 5.2.x

Postby Luffy_Senpai » 2016/05/15 18:21:51

remirepo wrote:PHP 5.3.3 is available in standard repo (php53* packages)

No other repo provides 5.2 which is EOL an unmaintained.


thanks for the response, however the reason why I need a lower version of the php is because, I have an old system and this one is running on Microsoft SQL server and according to the php site mssql is deprecated on php 5.3.x,. that' why if I upgraded it to the later version of the php and use Microsoft SQL Server Driver for PHP(sqlsrv) I'm afraid that it doesn't work on linux server, because based on the php site sqlsrv only works running on windows server.

can you give me the link to upgrade the version to PHP 5.3.3? or it is possible to manually install php from their website itself?
Sorry I don't enough that much knowledge on a linux server.

User avatar
remirepo
Posts: 250
Joined: 2014/09/21 09:07:12
Location: France
Contact:

Re: Help CentOS 5 Upgrade PHP to PHP 5.2.x

Postby remirepo » 2016/05/16 05:56:06

To update to 5.3, you need to remove add "php-*" package and install "php53-*" packages instead.

php53-mssql is available in EPEL repository.
Remi's Repository - Forum - Blog