Webmin not starting up

Support for webhosts that use CentOS
sysnub
Posts: 2
Joined: 2017/03/03 17:05:00

Webmin not starting up

Postby sysnub » 2017/03/03 17:18:32

I am running a mail server on a CENTOS 5.1 with Webmin 1.820. I rebooted the server because pop was not working. When the server came back online Webmin did not start. I don't know what I can do, if it is not fixable is it possible to do a back up from terminal then restore on a fresh install of webmin? any help will be much appreciated!

ps: Also I am new here but really looking forward to becoming an active member of this community!
Attachments
webmin-error.jpg
webmin-error.jpg (53.1 KiB) Viewed 1162 times

User avatar
TrevorH
Forum Moderator
Posts: 20566
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Webmin not starting up

Postby TrevorH » 2017/03/03 17:32:05

CentOS 5.1 :( Really? Congratulations, you win the most outdated server of the year 2017 so far. CentOS 5.1 was released in December 2007 and if you are really running 5.1 then you are missing the last *9 years* of security patches.

Also, CentOS 5 is about to reach End Of Life (EOL) and there will be no more security updates for it at all after the end of this month. You are strongly encouraged to move to a CentOS 7 server which has another 7 years of life left yet.

For your current problem, does the directory /var/webmin exist? If it doesn't, create it and give the user that webmin runs with write access to it so that it can store its pid file there.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

sysnub
Posts: 2
Joined: 2017/03/03 17:05:00

Re: Webmin not starting up

Postby sysnub » 2017/03/04 18:59:18

Awesome! it worked, I have no idea why that reboot would have caused errors, but it seems like all the settings are on default. I have cg-bin/openwebmail/openwebmail.pl was not found. If I update and reboot this server will this happen again?