SSI not working apache 2.2.3 CentOS 5.4

Support for webhosts that use CentOS
Post Reply
sftpfilecontrol
Posts: 1
Joined: 2010/05/07 16:02:08
Contact:

SSI not working apache 2.2.3 CentOS 5.4

Post by sftpfilecontrol » 2010/05/07 16:06:31

I'm having a dickens of a time getting server-side includes to work on Apache 2.2.3 on CentOS. I've taken all the usual steps. It simply does not work. It ignores any include directives. Anyone have any ideas? HEre's the relevant lines from httpd.conf:

[code]
LoadModule include_module modules/mod_include.so
AddHandler cgi-script .cgi
AddHandler server-parsed .shtml
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
<VirtualHost *:80>
DocumentRoot /var/sites/www
<Directory "/var/sites/www/cgi-bin">
Options ExecCGI
</Directory>
<Directory "/var/sites/www">
Options Indexes FollowSymLinks ExecCGI Includes
</Directory>
</VirtualHost>
[/code]
SELinux is disabled as shown below:

[root@s1 www]# getsebool -a
getsebool: SELinux is disabled

[Moderator edited to insert [i]code[/i] tags to preserve the format.]

wedgeshot
Posts: 17
Joined: 2010/01/27 04:25:53

SSI not working apache 2.2.3 CentOS 5.4

Post by wedgeshot » 2010/05/11 03:04:16

I've looked at our configs and I don't see the "AddHandler server-parsed .shtml" but we did have them back in our 1.3.x versions so for giggles try commenting that line out.

Any errors or statements in the log files?

Erris
Posts: 1
Joined: 2010/10/30 13:02:07
Location: Veendam (Netherlands)

Re: SSI not working apache 2.2.3 CentOS 5.4

Post by Erris » 2010/10/30 13:07:25

Pleasy try this, in your /etc/httpd/conf/httpd.conf

[code]
<Directory />
Options FollowSymLinks
Options +Includes
AllowOverride None
</Directory>
[/code]
if these are commented. uncomment them

AddType text/html .shtml
AddOutputFilter INCLUDES .shtml

safe your httpd.conf and restart, it worked at my server with CentOs 5.4

[Moderator edited to insert [i]code[/i] tags to preserve the format.]

Post Reply

Return to “CentOS 5 - Webhosting Support”