Integrating Apache with Tomcat on CentOS5.6

Support for webhosts that use CentOS
Post Reply
Rick_Smith
Posts: 87
Joined: 2011/10/07 11:32:23

Integrating Apache with Tomcat on CentOS5.6

Post by Rick_Smith » 2011/12/06 18:56:04

This document details the step by step guide to integrate apache with tomcat on CentOS5.6
It is available for download at: http://dl.dropbox.com/u/30415275/Integrating_tomcat_with_apache.pdf

Please don't hesitate to ask the author any questions

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Integrating Apache with Tomcat on CentOS5.6

Post by pschaff » 2011/12/06 21:00:39

The current CentOS-5 release if 5.7, not 5.6.

As with your [url=https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=34590&forum=43]previous recommendation[/url], [url=http://wiki.centos.org/PackageManagement/SourceInstalls]Source Installs[/url] are [b]highly[/b] discouraged. Apache (currently httpd-2.2.3-53.el5.centos.3) and Tomcat (currently tomcat5-5.5.23-0jpp.19.el5_6) are packages in the core distribution.

Try [code]yum list \*tomcat\* httpd\*[/code]to see what is available.

There are [url=http://wiki.centos.org/?action=fullsearch&context=180&value=Java&titlesearch=Titles]Wiki articles[/url] about installing Java although some additional work may be indicated in that department.

One is of course free to manage one's own system any way one pleases, but recommending guides with questionable procedures is not necessarily helpful.

Dariusz
Posts: 1
Joined: 2011/12/06 21:40:11

Re: Integrating Apache with Tomcat on CentOS5.6

Post by Dariusz » 2011/12/06 21:47:06

The developers in every company I have worked at want the latest stable release of apache/tomcat - this is only available via sources, hence the need to build from source. I find it useful to install missing libraries via yum.


Great step by step guides, please keep them coming.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Integrating Apache with Tomcat on CentOS5.6

Post by pschaff » 2011/12/06 22:45:14

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

As I said, feel free... It's your system, but in that case perhaps an [url=https://www.google.com/search?q=%22Enterprise+Linux%22&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&safe=active]Enterprise Linux[/url] release, particularly an N-1 release (el5 when el6 is available) is not the best choice for a platform.

[url=http://wiki.centos.org/FAQ/General#head-472ce8446ebcfc82ca1800f775ba0e629ac835c7]FAQ#20. Where can I get the latest version of XyZ.rpm for CentOS? I cannot find it anywhere.[/url]

If you [b]must[/b] still have later versions I'd recommend reading about [url=http://wiki.centos.org/HowTos/RebuildSRPM]how to rebuild SRPMs[/url] and finding Fedora or other SRPMs as a starting place for packages, rather than installing from a tarball and bypassing the package management system.

Post Reply

Return to “CentOS 5 - Webhosting Support”