[SOLVED] PHP date()-poblem after installing mod_wsgi

Support for webhosts that use CentOS
Post Reply
sparrow242
Posts: 2
Joined: 2012/06/29 15:51:27

[SOLVED] PHP date()-poblem after installing mod_wsgi

Post by sparrow242 » 2012/06/29 16:11:27

Hi there,

I have a strange problem with a CentOS 5-Installation:

After I installed mod_wsgi the time in PHP is random correct or 7 hours in the past. This happens when I call date() in PHP and also when PHP formats any date-strings. A webmailer which runs there shows the right incoming-time for mails, after a reload of the page the time 7 hours before ther right time, it is absolute random.

I have no idea, first I thought it could be the timezone, but setting it (or mark it as comment like default) in the /etc/php.ini takes no effect.

After deactivate mod_wsgi everything ist ok.

Any suggestions?


Cheers

Sebastian

sparrow242
Posts: 2
Joined: 2012/06/29 15:51:27

Re: PHP date()-poblem after installing mod_wsgi

Post by sparrow242 » 2012/07/02 07:00:18

Hah, solved it! For the record:
There was a wrong timezone-setting in the configuration of the wsgi-application. I have no idea why that affected the php-environment, but it had.

User avatar
AlanBartlett
Forum Moderator
Posts: 9323
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

[SOLVED] PHP date()-poblem after installing mod_wsgi

Post by AlanBartlett » 2012/07/03 02:03:57

Thank you for reporting back.

On your behalf and for posterity, this thread is now marked [SOLVED].

Post Reply

Return to “CentOS 5 - Webhosting Support”