Unable to "yum install openssl-devel" - man page conflicts.

Support for the other architectures (X86_64, IA-64, and PowerPC)
Post Reply
arrkerr
Posts: 4
Joined: 2007/04/13 13:46:04
Location: Ann Arbor, MI

Unable to "yum install openssl-devel" - man page conflicts.

Post by arrkerr » 2007/04/17 15:58:09

This is from a clean load of CentOS-5, no packages checked during installation.

I need to install openssl-devel, but it is trying to add openssl for i686, and openssl for x86_64 is already installed.

[root@bpel-dev-db1 ~]# rpm -q --queryformat='%{name}-%{version}-%{release}.%{arch}\n' openssl
openssl-0.9.8b-8.3.el5.x86_64

[root@bpel-dev-db1 ~]# yum install openssl-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package openssl-devel.x86_64 0:0.9.8b-8.3.el5 set to be updated
---> Package openssl-devel.i386 0:0.9.8b-8.3.el5 set to be updated
--> Running transaction check
--> Processing Dependency: libcrypto.so.6 for package: openssl-devel
--> Processing Dependency: libssl.so.6 for package: openssl-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package openssl.i686 0:0.9.8b-8.3.el5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
openssl-devel x86_64 0.9.8b-8.3.el5 base 1.8 M
openssl-devel i386 0.9.8b-8.3.el5 base 1.8 M
Installing for dependencies:
openssl i686 0.9.8b-8.3.el5 base 1.4 M

Transaction Summary
=============================================================================
Install 3 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 5.1 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/share/man/man1/asn1parse.1ssl.gz from install of openssl-0.9.8b-8.3.el5 conflicts with file from package openssl-0.9.8b-8.3.el5
file /usr/share/man/man1/nseq.1ssl.gz from install of openssl-0.9.8b-8.3.el5 conflicts with file from package openssl-0.9.8b-8.3.el5
file /usr/share/man/man1/ocsp.1ssl.gz from install of openssl-0.9.8b-8.3.el5 conflicts with file from package openssl-0.9.8b-8.3.el5
file /usr/share/man/man1/smime.1ssl.gz from install of openssl-0.9.8b-8.3.el5 conflicts with file from package openssl-0.9.8b-8.3.el5

Error Summary
-------------

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Unable to "yum install openssl-devel" - man page conflicts.

Post by Lenard » 2007/04/17 16:53:42

No reason to install openssl-devel.i386;

yum install openssl.i386 openssl-devel.x86_64

rpdmiranda
Posts: 4
Joined: 2007/04/19 12:13:46
Location: Brazil

Re: Unable to "yum install openssl-devel" - man page conflicts.

Post by rpdmiranda » 2007/04/19 12:23:16

yum groupinstall "KDE (K Desktop Environment)" also gives me the same problem...

I did an upgrade from CentOS 4.4_Server CD

Thanks

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: Unable to "yum install openssl-devel" - man page conflicts.

Post by Lenard » 2007/04/19 15:33:04

Try; yum install kdebase kdelibs arts kde-multimedia

rpdmiranda
Posts: 4
Joined: 2007/04/19 12:13:46
Location: Brazil

Re: Unable to "yum install openssl-devel" - man page conflicts.

Post by rpdmiranda » 2007/04/19 16:51:39

I got it to work using
yum insall kdebase.x86_64 kdelibs.x86_64 kdemultimedia.x86_64

Yum was trying to install both the 32- and 64-bit versions of each package.

Post Reply

Return to “CentOS 5 - X86_64,s390(x) and PowerPC Support”