centOS - glade3 for c, php-gtk with phpize and php-config

Support for the other architectures (X86_64, IA-64, and PowerPC)
Post Reply
shamun
Posts: 20
Joined: 2010/02/03 11:53:32
Location: Belgium

centOS - glade3 for c, php-gtk with phpize and php-config

Post by shamun » 2010/02/18 10:16:15

I understand centOS shift with all as it get released. But in some case, i have a program written in C/Php-gtk using Glade3. Big problem is now facing centOS have glade2 and related glib/gtk/pango/cairo all old releases + php-gtk seems to be a night mare for me.


1. to have glade3 ( i need glib, gtk, atk, pango, cairo as following)

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.21.3 atk >= 1.13.0 pango >= 1.20 cairo >= 1.6) were not met:

Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.12.3
Requested 'atk >= 1.13.0' but version of Atk is 1.12.2
Requested 'pango >= 1.20' but version of Pango is 1.14.9
Requested 'cairo >= 1.6' but version of cairo is 1.2.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

2. to have php-gtk ( i need phpize, php-config)


Any idea if that possible or some hints on this?

Thanks in advance

shamun
Posts: 20
Joined: 2010/02/03 11:53:32
Location: Belgium

Re: centOS - glade3 for c, php-gtk with phpize and php-config

Post by shamun » 2010/02/18 13:07:09

* to have phpize/php-config i did this, so php is fine now.
$ yum -y install php-devel
[root@www modules]# phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

[root@www modules]# phpize --help
Usage: /usr/bin/phpize [--clean|--help|--version|-v]
[root@www modules]# phpize --v
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

[root@www modules]# phpize -v
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20050922
Zend Extension Api No: 220051025
[root@www modules]# php-config
Usage: /usr/bin/php-config [--prefix|--includes|--ldflags|--libs|--extension-dir|--include-dir|--php-binary|--version]
[root@www modules]#

Post Reply

Return to “CentOS 5 - X86_64,s390(x) and PowerPC Support”