Enabling SSL (mod_ssl) installation failure

Support for the other architectures (X86_64, IA-64, and PowerPC)
Post Reply
shylesh
Posts: 1
Joined: 2010/03/11 10:38:03

Enabling SSL (mod_ssl) installation failure

Post by shylesh » 2010/03/11 10:47:48

Hi,

I have the http apache server running fine. But now trying to enabled the ssl, and I did a yum install mod_ssl which returns this result below. Read through various posts and forms and tried different thing stated there but still no luck.
Appreiciate if anyone could advice on how I could fix this

Linux localhost 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:32:21 EST 2010 x86_64 x86_64 x86_64 GNU/Linux


[root@ca:/usr/src/kernels]$ yum install mod_ssl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: mirrors.netdna.com
* base: yum.singlehop.com
* extras: mirror.sanctuaryhost.com
* updates: yum.singlehop.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mod_ssl.x86_64 1:2.2.3-31.el5.centos.2 set to be updated
--> Processing Dependency: httpd = 2.2.3-31.el5.centos.2 for package: mod_ssl
--> Processing Dependency: libdistcache.so.1()(64bit) for package: mod_ssl
--> Processing Dependency: libnal.so.1()(64bit) for package: mod_ssl
--> Running transaction check
---> Package distcache.x86_64 0:1.4.5-14.1 set to be updated
---> Package mod_ssl.x86_64 1:2.2.3-31.el5.centos.2 set to be updated
--> Processing Dependency: httpd = 2.2.3-31.el5.centos.2 for package: mod_ssl
--> Finished Dependency Resolution
1:mod_ssl-2.2.3-31.el5.centos.2.x86_64 from updates has depsolving problems
--> Missing Dependency: httpd = 2.2.3-31.el5.centos.2 is needed by package 1:mod_ssl-2.2.3-31.el5.centos.2.x86_64 (updates)
Error: Missing Dependency: httpd = 2.2.3-31.el5.centos.2 is needed by package 1:mod_ssl-2.2.3-31.el5.centos.2.x86_64 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

User avatar
TrevorH
Forum Moderator
Posts: 25822
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Enabling SSL (mod_ssl) installation failure

Post by TrevorH » 2010/03/11 12:47:01

Run `rpm -q httpd` and check that it has the required version that you listed before. If it does not then you need to update it to the latest version in order that it matches the mod_ssl version that you want to install.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Enabling SSL (mod_ssl) installation failure

Post by pschaff » 2010/03/12 18:53:37

[quote]
shylesh wrote:
...
Error: Missing Dependency: httpd = 2.2.3-31.el5.centos.2 is needed by package 1:mod_ssl-2.2.3-31.el5.centos.2.x86_64 (updates)
....[/quote]

Those seem to be the current CentOS versions. Have you installed a 3rd party httpd package of a different version?
[code]
# rpm -q mod_ssl httpd
mod_ssl-2.2.3-31.el5.centos.2.x86_64
httpd-2.2.3-31.el5.centos.2.x86_64
[/code]
Never hurts to "yum clean all" and try again.

Post Reply