Looking for a package with "libXp.so.6"

Installation and support for Oracle DB on CentOS.
regtaman
Posts: 21
Joined: 2008/05/30 10:57:03
Location: Paris, France

Looking for a package with "libXp.so.6"

Postby regtaman » 2008/06/13 10:53:11

I've successfully installed CentOS 5.1 on my 2 PCs, which I'm currently using, and I've had no major problems with that so far. I'm now trying to install Oracle Clusterware and Oracle Database 10gR2 on that platform, and there I hit a problem. The installation aborts at the very beginning with the following error message :

Exception java.lang.UnsatisfiedLinkError:
/tmp/OraInstall2008-06-12_10-05-45PM/jre/1.4.2/lib/i386/libawt.so: libXp.so.6:
cannot open shared object file: No such file or directory occurred.

After looking at the Oracle Metalink site, it would appear that this is because the Oracle installation is looking for a deprecated shared library object called "libXp.so.6" which it can't find, and they (Oracle) suggest that one of the following packages be installed to resolve that problem :
- xorg-x11-deprecated-libs-6.8.2-1.EL.13.20.i386.rpm
- XFree86-libs-4.3.0-78.EL.i386.rpm
Both of those packages contain the library object in question, and both should apparently be on one of the Red Hat EL5 installation CDs. Unfortunately, it would appear that neither is on my CentOS installation CD. After doing a bit of research on the internet, it would appear that those packages are in the CentOS 4 distribution, but not in CentOS 5.

My question is - can I install one of those packages from a CentOS 4 distribution on my CentOS 5 platform ?

Unfortunately, I don't think I'd get very far if I approach Oracle with that problem, as they would only support a Red Hat platform (plus some others), but not CentOS.

Regards,

Reg TAMAN

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Looking for a package with "libXp.so.6"

Postby gerald_clark » 2008/06/13 13:09:25

Do not double post.

manitou
Posts: 2
Joined: 2008/07/18 20:13:11

Re: Looking for a package with "libXp.so.6"

Postby manitou » 2008/07/18 20:15:06

this error means that there is no xorg-x11-deprecated-libs package installed

you should probably read through this page

http://ivan.kartik.sk/oracle/install_or ... edora.html

seismo
Posts: 16
Joined: 2007/03/22 21:44:26
Contact:

Re: Looking for a package with "libXp.so.6"

Postby seismo » 2008/09/11 01:29:53

yum install libXp

apis17
Posts: 1
Joined: 2010/07/26 09:27:06

Re: Looking for a package with "libXp.so.6"

Postby apis17 » 2010/07/26 09:29:40

if all fails try this

yum install xorg-x11-utils

regards