Problem installing Oracle 10.1.2 on CentOS 5.2

Installation and support for Oracle DB on CentOS.
Post Reply
Ravenman
Posts: 4
Joined: 2009/03/09 22:30:00

Problem installing Oracle 10.1.2 on CentOS 5.2

Post by Ravenman » 2009/03/10 14:06:56

Hi to all.

I'm installing Oracle Application Server 10g Release 2 (10.1.2) on CentOS 5.2.

The installation of Oracle AS Infrastructure was successful, but I have one problem installing the Business Intelligence and Forms Middle tier.

I'm watching in the log and I have found this:

Start output from spawned process:
----------------------------------
rm -f rwproxy
gcc -o rwproxy -L/opt/oracle/oraMiddle//lib/ -L/opt/oracle/oraMiddle/lib/ -L/opt/oracle/oraMiddle/lib//stubs -rdynamic -Bdynamic -L/opt/oracle/oraMiddle/jdk/jre/lib/i386 -L/opt/oracle/oraMiddle/jdk/jre/lib/i386/server -L/opt/oracle/oraMiddle/jdk/jre/lib/i386/native_threads -ljvm srwsps.o rwsdm.o rwsps.o \
-Wl,-rpath,/usr/X11R6/lib -L/usr/X11R6/lib -lXm -lXt -lX11 -lm -lXp -lXext /opt/oracle/oraMiddle/lib//libzrc.a -lca -lnn -lrw -lclntsh `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lnro10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lmm -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lnro10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 `cat /opt/oracle/oraMiddle/lib/sysliblist` -Wl,-rpath,/opt/oracle/oraMiddle/lib,-rpath,/opt/oracle/oraMiddle/jdk/jre/lib/i386:/lib:/usr/lib -lm `cat /opt/oracle/oraMiddle/lib/sysliblist` -ldl -lpthread -lm -L/opt/oracle/oraMiddle/lib -L/opt/oracle/oraMiddle/lib/stubs/ -lutj -lutl -ljvm -lhpi -nsl
gcc: unrecognized option '-nsl'
/usr/lib/libXtst.so.6: undefined reference to `__stack_chk_fail@GLIBC_2.4'
/usr/lib/libXtst.so.6: undefined reference to `__fprintf_chk@GLIBC_2.3.4'
/usr/lib/libXtst.so.6: undefined reference to `__sprintf_chk@GLIBC_2.3.4'
collect2: ld returned 1 exit status
make: *** [rwproxy] Error 1

End output from spawned process.
----------------------------------
Exception thrown from action: make
Exception Name: MakefileException
Exception String: Error in invoking target 'proxy_install runm_install server_install cgi_install cli_install conv_install qv_install' of makefile '/opt/oracle/oraMiddle/reports/lib/ins_reports.mk'. See '/opt/oracle/oraInventory/logs/installActions2009-03-09_10-23-30AM.log' for details.
Exception Severity: 1

I don't know what to do here :-? ... can anyone help me, please ? :-)

regged
Posts: 1
Joined: 2009/03/12 21:58:41

Re: Problem installing Oracle 10.1.2 on CentOS 5.2

Post by regged » 2009/03/12 22:03:58

Hi,

Check out the following which describes a similar problem and "fix".

http://bytes.com/topic/oracle/answers/722608-oracle-developer-suite-10-1-2-0-2-installation-fedora-5-a

Regards

Mark

tmar
Posts: 8
Joined: 2009/03/24 10:09:24

Re: Problem installing Oracle 10.1.2 on CentOS 5.2

Post by tmar » 2009/03/24 11:50:50

Hello,

I am trying to install Oracle Application Server Release 10.1.2.0.2 on Centos 5.2, with no success. I have followed the instructions from the oracle installation guide, (but for RHL4 ) but I am getting the error :

Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-2.1, redhat-3, redhat-4, SuSE-8, SuSE-9 or UnitedLinux-1.0
Failed <<<<


Could you please give me more information regarding the installation?


thank you

[quote]
Ravenman wrote:
Hi to all.

I'm installing Oracle Application Server 10g Release 2 (10.1.2) on CentOS 5.2.

The installation of Oracle AS Infrastructure was successful, but I have one problem installing the Business Intelligence and Forms Middle tier.

I'm watching in the log and I have found this:

Start output from spawned process:
----------------------------------
rm -f rwproxy
gcc -o rwproxy -L/opt/oracle/oraMiddle//lib/ -L/opt/oracle/oraMiddle/lib/ -L/opt/oracle/oraMiddle/lib//stubs -rdynamic -Bdynamic -L/opt/oracle/oraMiddle/jdk/jre/lib/i386 -L/opt/oracle/oraMiddle/jdk/jre/lib/i386/server -L/opt/oracle/oraMiddle/jdk/jre/lib/i386/native_threads -ljvm srwsps.o rwsdm.o rwsps.o \
-Wl,-rpath,/usr/X11R6/lib -L/usr/X11R6/lib -lXm -lXt -lX11 -lm -lXp -lXext /opt/oracle/oraMiddle/lib//libzrc.a -lca -lnn -lrw -lclntsh `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lnro10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lmm -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lnro10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 `cat /opt/oracle/oraMiddle/lib/sysliblist` -Wl,-rpath,/opt/oracle/oraMiddle/lib,-rpath,/opt/oracle/oraMiddle/jdk/jre/lib/i386:/lib:/usr/lib -lm `cat /opt/oracle/oraMiddle/lib/sysliblist` -ldl -lpthread -lm -L/opt/oracle/oraMiddle/lib -L/opt/oracle/oraMiddle/lib/stubs/ -lutj -lutl -ljvm -lhpi -nsl
gcc: unrecognized option '-nsl'
/usr/lib/libXtst.so.6: undefined reference to `__stack_chk_fail@GLIBC_2.4'
/usr/lib/libXtst.so.6: undefined reference to `__fprintf_chk@GLIBC_2.3.4'
/usr/lib/libXtst.so.6: undefined reference to `__sprintf_chk@GLIBC_2.3.4'
collect2: ld returned 1 exit status
make: *** [rwproxy] Error 1

End output from spawned process.
----------------------------------
Exception thrown from action: make
Exception Name: MakefileException
Exception String: Error in invoking target 'proxy_install runm_install server_install cgi_install cli_install conv_install qv_install' of makefile '/opt/oracle/oraMiddle/reports/lib/ins_reports.mk'. See '/opt/oracle/oraInventory/logs/installActions2009-03-09_10-23-30AM.log' for details.
Exception Severity: 1

I don't know what to do here :-? ... can anyone help me, please ? :-)[/quote]

fredex
Posts: 15
Joined: 2009/04/13 01:45:06

Re: Problem installing Oracle 10.1.2 on CentOS 5.2

Post by fredex » 2009/04/13 02:03:34

[quote]Checking operating system version: must be redhat-2.1, redhat-3, redhat-4, SuSE-8, SuSE-9 or UnitedLinux-1.0
Failed <<<<[/quote]

Oracle checks the contents of /etc/redhat-release. Centos also has this file, but it does not contain the same text as it does on a "real" redhat system. You need to temporarily rename the existing file and put in one containing the same text as a "real" red hat system for the RH version equivalent to the Centos version you're using. Sorry, I don't know, just off the top'o'my head what that text is.

polo1308
Posts: 1
Joined: 2009/04/13 17:08:06

Re: Problem installing Oracle 10.1.2 on CentOS 5.2

Post by polo1308 » 2009/04/13 17:17:51

Hi, if your CentOS installacion its 64 bits, you need this package libXp.i386

Oracle use x86 compatibility

greats.

Sorry for my bad english.[quote]
fredex wrote:
[quote]Checking operating system version: must be redhat-2.1, redhat-3, redhat-4, SuSE-8, SuSE-9 or UnitedLinux-1.0
Failed <<<<[/quote]

Oracle checks the contents of /etc/redhat-release. Centos also has this file, but it does not contain the same text as it does on a "real" redhat system. You need to temporarily rename the existing file and put in one containing the same text as a "real" red hat system for the RH version equivalent to the Centos version you're using. Sorry, I don't know, just off the top'o'my head what that text is.[/quote]

peter_knight
Posts: 1
Joined: 2009/04/26 13:42:32

Re: Problem installing Oracle 10.1.2 on CentOS 5.2

Post by peter_knight » 2009/04/26 13:49:39

A very useful site for these types of problems is http://www.oracle-base.com/ - authored by Tim Hall.

To fix the problem about the version not being supported, edit the file
/etc/redhat-release to contain:

redhat-4

in a single line.

That's it.

animeboy
Posts: 1
Joined: 2009/04/27 20:41:35

Re: Problem installing Oracle 10.1.2 on CentOS 5.2

Post by animeboy » 2009/04/27 20:44:09

[quote]
Ravenman wrote:
Hi to all.

I'm installing Oracle Application Server 10g Release 2 (10.1.2) on CentOS 5.2.

The installation of Oracle AS Infrastructure was successful, but I have one problem installing the Business Intelligence and Forms Middle tier.

I'm watching in the log and I have found this:

Start output from spawned process:
----------------------------------
rm -f rwproxy
gcc -o rwproxy -L/opt/oracle/oraMiddle//lib/ -L/opt/oracle/oraMiddle/lib/ -L/opt/oracle/oraMiddle/lib//stubs -rdynamic -Bdynamic -L/opt/oracle/oraMiddle/jdk/jre/lib/i386 -L/opt/oracle/oraMiddle/jdk/jre/lib/i386/server -L/opt/oracle/oraMiddle/jdk/jre/lib/i386/native_threads -ljvm srwsps.o rwsdm.o rwsps.o \
-Wl,-rpath,/usr/X11R6/lib -L/usr/X11R6/lib -lXm -lXt -lX11 -lm -lXp -lXext /opt/oracle/oraMiddle/lib//libzrc.a -lca -lnn -lrw -lclntsh `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lnro10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lmm -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lnro10 `cat /opt/oracle/oraMiddle/lib/ldflags` -lnsslb10 -lnsgr10 -lnzjs10 -ln10 -lnnz10 -lnl10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 -lclient10 -lnnetd10 -lvsn10 -lcommon10 -lgeneric10 -lcore10 -lunls10 -lsnls10 -lnls10 -lcore10 -lnls10 `cat /opt/oracle/oraMiddle/lib/sysliblist` -Wl,-rpath,/opt/oracle/oraMiddle/lib,-rpath,/opt/oracle/oraMiddle/jdk/jre/lib/i386:/lib:/usr/lib -lm `cat /opt/oracle/oraMiddle/lib/sysliblist` -ldl -lpthread -lm -L/opt/oracle/oraMiddle/lib -L/opt/oracle/oraMiddle/lib/stubs/ -lutj -lutl -ljvm -lhpi -nsl
gcc: unrecognized option '-nsl'
/usr/lib/libXtst.so.6: undefined reference to `__stack_chk_fail@GLIBC_2.4'
/usr/lib/libXtst.so.6: undefined reference to `__fprintf_chk@GLIBC_2.3.4'
/usr/lib/libXtst.so.6: undefined reference to `__sprintf_chk@GLIBC_2.3.4'
collect2: ld returned 1 exit status
make: *** [rwproxy] Error 1


I don't know what to do here :-? ... can anyone help me, please ? :-)[/quote]

A) The following i386 packages are not part of the OS distribution media and must be downloaded separately (from http://oss.oracle.com/projects/compat-oracle/files/Enterprise_Linux for both OEL 5 and RHEL 5) and installed manually:

* openmotif21-2.1.30-11.EL5.i3861
* xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386
* binutils-2.17.50.0.6-6.0.1.i3862

B) Link to Motif library for Oracle Application Server 10.1.2 (on OEL 5 and RHEL 5 only)

Perform the following command (as root on your system) to update a required link to a Motif library prior to relinking or patching the 10.1.2 Application Server Oracle Home:

# unlink /usr/lib/libXtst.so.6
# ln -s /usr/X11R6/lib/libXtst.so.6.1 /usr/lib/libXtst.so.6

Without this updated link, you may see the following errors during a relink of the 10.1.2 Oracle Home:

/usr/lib/libXtst.so.6: undefined reference to `__stack_chk_fail@GLIBC_2.4'
/usr/lib/libXtst.so.6: undefined reference to `__fprintf_chk@GLIBC_2.3.4'
/usr/lib/libXtst.so.6: undefined reference to `__sprintf_chk@GLIBC_2.3.4'

Since the ldconfig command overrides this link, the above link command (ln) will have to be re-issued after running the ldconfig command.


If you have Metalink access, Note: 402310.1 is a reference for this.

Post Reply

Return to “CentOS 5 - Oracle Installation and Support”