trouble installing oracle 10

Installation and support for Oracle DB on CentOS.
shiko
Posts: 1
Joined: 2011/02/02 21:22:19

trouble installing oracle 10

Postby shiko » 2011/02/02 21:28:00

Hi, I'm trying to install oracle 10 on a computer with Linux (CentOS).

After performing the pre-installation.

When executing the instruction. / runInstaller, it generates the following error:

Exception in thread "main" java.lang.UnsatisfiedLinkError: / tmp/OraInstall2011-02-02_05-14-48PM/jre/1.4.2/lib/i386/libawt.so: libXp.so.6: can not open shared object file : No such file or directory

I searched for a solution several forums but have not found anything yet, I hope I can help.

Thank you very much.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

trouble installing oracle 10

Postby pschaff » 2011/02/02 22:59:57

Welcome to the CentOS fora. Reading FAQ & Readme First is recommended for new users.

Code: Select all

[root@c5 ~]# locate libXp.so.6
/usr/lib/libXp.so.6
/usr/lib/libXp.so.6.2.0
[root@c5 ~]# rpm -qf /usr/lib/libXp.so.6
libXp-1.0.0-8.1.el5

Do you have libXp installed?

rsavela
Posts: 1
Joined: 2011/02/12 17:59:10
Contact:

Re: trouble installing oracle 10

Postby rsavela » 2011/02/12 18:03:35

If you are using an x86_64 version of CentOS, you will need the 32 bit version of libXp. There are a fair number of other prereqs as well for Oracle.

This list should cover you, refer to Metalink for the official requirements.


compat-libstdc++-33.i386
libXp.i386
glibc-common
gdbm-devel.i386
sysstat
gdbm-devel.x86_64
make
@dialup
libstdc++
compat-libstdc++-33.x86_64
@base-x
compat-libstdc++-296.i386
@base
glibc
gdbm.i386
gcc-c++
glibc-devel.i386
device-mapper-multipath
compat-db
kernel-devel
glibc-devel.x86_64
libaio
libstdc++-devel
gdb.x86_64
gcc
-zsh
@system-tools
-xdelta
device-mapper-multipath.x86_64
binutils
-openldap-clients
unixODBC-devel
unixODBC
libaio-devel