Unable to install gcc on centos

If it doesn't fit in another category, ask it here.
Post Reply
izharzabri
Posts: 1
Joined: 2014/02/18 11:04:14

Unable to install gcc on centos

Post by izharzabri » 2014/02/18 11:13:16

Hi,

I try to install gcc on my machine however it shows dependencies error as below. Please guide.

# yum install gcc-4.4.7-4.el6.x86_64 --skip-broken
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: centos.ipserverone.com
* extras: centos.ipserverone.com
* updates: centos.ipserverone.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.4.7-4.el6 will be installed
--> Processing Dependency: cpp = 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.7-4.el6.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.7-4.el6.x86_64
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
--> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
--> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
---> Package cpp.x86_64 0:4.4.7-4.el6 will be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.7-4.el6.x86_64
---> Package glibc-devel.x86_64 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-headers = 2.12-1.132.el6 for package: glibc-devel-2.12-1.132.el6.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.132.el6.x86_64
--> Running transaction check
---> Package glibc-headers.x86_64 0:2.12-1.132.el6 will be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.132.el6.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.132.el6.x86_64
---> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
---> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.12-1.132.el6 will be installed
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.7-4.el6.x86_64
---> Package glibc-headers.x86_64 0:2.12-1.132.el6 will be installed

Packages skipped because of dependency problems:
cloog-ppl-0.15.7-1.2.el6.x86_64 from base
cpp-4.4.7-4.el6.x86_64 from base
gcc-4.4.7-4.el6.x86_64 from base
glibc-devel-2.12-1.132.el6.x86_64 from base
glibc-headers-2.12-1.132.el6.x86_64 from base
mpfr-2.4.1-6.el6.x86_64 from base
ppl-0.10.2-11.el6.x86_64 from base

Thanks.

User avatar
avij
Retired Moderator
Posts: 3039
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Unable to install gcc on centos

Post by avij » 2014/02/18 11:50:51

You posted this on the CentOS 5 - Miscellaneous Questions subforum, so I'm assuming you are using CentOS 5. You seem to be trying to install a CentOS 6 package (el6). Installing CentOS 6 packages on CentOS 5 will not work. To install the gcc of CentOS 5, "yum install gcc" will do just fine.

Post Reply

Return to “CentOS 5 - Miscellaneous Questions”