[SOLVED] Yum breakage now that CentOS 4 has moved to the vault. Solution?

General support questions including new installations
daleforester
Posts: 2
Joined: 2012/03/23 14:54:22

[SOLVED] Yum breakage now that CentOS 4 has moved to the vault. Solution?

Postby daleforester » 2012/03/23 14:57:49

Yum breaks now that centos4 has moved to the vault. There is still value in installing existing software via yum. How can I fix this?

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

[SOLVED] Yum breakage now that CentOS 4 has moved to the vau

Postby pschaff » 2012/03/23 15:48:35

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Change your yum repos to point to http://vault.centos.org/4.9/ and plan your migration to a supported version.

daleforester
Posts: 2
Joined: 2012/03/23 14:54:22

Re: Yum breakage now that CentOS 4 has moved to the vault. Solution? (SOLVED)

Postby daleforester » 2012/03/23 21:44:41

Thank you. I was able to make this work by commenting out mirrorlist directives and adding baseurl=http://vault.centos.org/4.9/os/$basearch in /etc/yum.repos.d/CentOS-Base.repo for enabled sections.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: [SOLVED] Yum breakage now that CentOS 4 has moved to the vault. Solution? (SOLVED)

Postby pschaff » 2012/03/23 23:40:54

You are welcome. Thanks for reporting back. Marking this thread [SOLVED] for posterity.