Httpd and MySQL Query Errors

Issues related to software problems
Post Reply
WeeHughie
Posts: 9
Joined: 2006/02/26 19:39:15
Location: Ontario, Canada

Httpd and MySQL Query Errors

Post by WeeHughie » 2008/12/04 19:13:11

As per this thread: http://www.centos.org/modules/newbb/viewtopic.php?topic_id=16672&forum=28

I upgraded my CentOS 4.7 installation to PHP 5 and MySQL 5.

Then, I also upgraded httpd to 2.0.63 from 2.0.52-41.

When I did that, I'd get frequent issues with sites using MySQL and PHP - issues with being unable to connect to the database. /var/log/messages showed httpd segfaulting with "error 6."

I ended up downgrading back to httpd 2.0.52. The database connection problems remain, however no segfaults in the messages log.

Restarting httpd resolves the problem for a time (note: MySQL seems to be fine and does not need to be restarted).

I'm running:
AMD Athlon(tm) 64 Processor 3200+
2 GB RAM
Centos 4.7

rpm -qa |grep mysql
libdbi-dbd-mysql-0.6.5-10.RHEL4.1
mysqlclient10-3.23.58-9.2.c4
mysql-server-5.0.68-1.el4_6
mysqlclient14-4.1.22-1.el4s1.1
mysql-devel-5.0.68-1.el4_6
mysqlclient10-3.23.58-4.RHEL4.1
php-mysql-5.1.6-3.el4s1.10
mod_auth_mysql-2.6.1-2.2
mysql-5.0.68-1.el4_6
mysql-libs-5.0.68-1.el4_6

rpm -qa |grep httpd
httpd-2.0.52-41.ent.2.centos4
system-config-httpd-1.3.1-1
httpd-devel-2.0.52-41.ent.2.centos4
httpd-suexec-2.0.52-41.ent.2.centos4

rpm -qa|grep php
php-5.1.6-3.el4s1.10
php-gd-5.1.6-3.el4s1.10
php-pdo-5.1.6-3.el4s1.10
php-pear-1.4.11-1.el4s1.1
php-cli-5.1.6-3.el4s1.10
php-mysql-5.1.6-3.el4s1.10
php-common-5.1.6-3.el4s1.10

I'm wondering if anyone else has had similar issues and might be able to point me in the right direction where to start looking to solve the problem where php and/or httpd have problems with MySQL?

Thanks,

Ian

Post Reply