Squid proxy

Issues related to software problems
Post Reply
xavibuf
Posts: 5
Joined: 2009/05/21 14:40:47

Squid proxy

Post by xavibuf » 2009/05/21 14:47:34

I need to install Squid 2.6.X with CentOS 4.7. I have installed Squid 2.5.14 (it is in the repositories), and I know that Centos 5 includes Squid 2.6, but I need Squid 2.6 + CentOS 4.7.

Is it possible? I don't know how to install it. I tried to install the 2.6 RPM but it has many unresolved dependencies.

Thanks,

Xavi

pjwelsh
Posts: 2598
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Squid proxy

Post by pjwelsh » 2009/05/21 15:18:31

It is modestly trivial (most of the time) to rebuild the .src.rpm for common auxiliary apps like squid. Grab a 4.x test box, install the devel tools, build the .src.rpm from 5.x and test. There may be a repo that has done the work for you. A quick google'n will help. Something like "squid 2.6 el4" or similar.

xavibuf
Posts: 5
Joined: 2009/05/21 14:40:47

Re: Squid proxy

Post by xavibuf » 2009/05/21 15:32:58

I have searched what you suggest but I don't find the package. I have downloaded squid-2.5.STABLE14-4.el4.i386.rpm and squid-2.6.STABLE21-3.el5.i386.rpm.

Whay you say is searching something like squid-[b]2.6[/b].STABLE21-3.[b]el4[/b].i386.rpm?

Thanks

pjwelsh
Posts: 2598
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: Squid proxy

Post by pjwelsh » 2009/05/21 15:55:34

I don't think your downloaded binary of "squid-2.6.STABLE21-3.el5.i386.rpm" will drop right into your CentOS 4.x install. It may. I've not tried it and would not in this kind of situation. What I suggest is you get the SOURCE rpm for squid-2.6.STABLE21-3.el5.src.rpm and rebuild that onto a 4.7 dev setup. Since this isn't making as much sense as I had hoped to you, you may not be a good candidate to build the source on your own. So, the magic google incantation I tried was "squid-2.6 el4 rpm" and my first link was one click from getting what you likely want ;)
http://rpm.pbone.net/index.php3/stat/4/idpl/12208939/com/squid26-2.6.STABLE22-1.el4.pp.i386.rpm.html

However, I have not attempted this install since I don't have 4.x running squid. Please be aware of possible third party install issues:
http://wiki.centos.org/AdditionalResources/Repositories
Pay attention to the "3rd Party Repositories" section, please.

xavibuf
Posts: 5
Joined: 2009/05/21 14:40:47

Re: Squid proxy

Post by xavibuf » 2009/05/21 16:00:48

Yes, I have find it too :P. But now I don't have the public key...

Public key for squid26-2.6.STABLE22-1.el4.pp.i386.rpm is not installed


And I don't know where to find it. yum --nogpgcheck doesn't work.

Thanks a lot,

Xavi

pjwelsh
Posts: 2598
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: Squid proxy

Post by pjwelsh » 2009/05/21 17:55:52

"rpm" is more forgiving about the key:
[code]rpm -ihv squid26-2.6.STABLE22-1.el4.pp.i386.rpm[/code]

xavibuf
Posts: 5
Joined: 2009/05/21 14:40:47

Re: Squid proxy

Post by xavibuf » 2009/05/22 07:15:01

Thanks a lot!!

[root@XX squid26]# squid -v
Squid Cache: Version 2.6.STABLE22

Post Reply

Return to “CentOS 4 - Software Support”