Trying to install courier-authlib* packages(get missing dependeny)

Issues related to software problems
Post Reply
thabang
Posts: 19
Joined: 2009/05/12 10:32:59

Trying to install courier-authlib* packages(get missing dependeny)

Post by thabang » 2009/08/28 10:28:38

rpm -ivh /home/rpmbuild/rpm/RPMS/i386/courier-authlib-0.59.3-10.i386.rpm* /home/rpmbuild/rpm/RPMS/i386/courier-authlib-devel-0.59.3-10.i386.rpm* /home/rpmbuild/rpm/RPMS/i386/courier-authlib-mysql-0.59.3-10.i386.rpm*

Hi

I used the above command to load the packges on my centos4.7 server and i got the error:Missing dependency and the dependency that are missing are as follow:
error: Failed dependencies:
libc.so.6(GLIBC_2.4) is needed by courier-authlib-0.59.3-10.i386
libgdbm.so.2 is needed by courier-authlib-0.59.3-10.i386
libltdl.so.3 is needed by courier-authlib-0.59.3-10.i386
libpam.so.0(LIBPAM_1.0) is needed by courier-authlib-0.59.3-10.i386
rtld(GNU_HASH) is needed by courier-authlib-0.59.3-10.i386
rtld(GNU_HASH) is needed by courier-authlib-devel-0.59.3-10.i386
libcrypto.so.6 is needed by courier-authlib-mysql-0.59.3-10.i386
libmysqlclient.so.15 is needed by courier-authlib-mysql-0.59.3-10.i386
libmysqlclient.so.15(libmysqlclient_15) is needed by courier-authlib-mysql-0.59.3-10.i386
libssl.so.6 is needed by courier-authlib-mysql-0.59.3-10.i386
rtld(GNU_HASH) is needed by courier-authlib-mysql-0.59.3-10.i386
Can anybody help on how i can get the following dependeny because i tried to search for them over the nternet.I can't find them!Or anybody who can help me get the command to install the package and it's needed dependency at the same time.

PLEASE HELP ME!!

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Trying to install courier-authlib* packages(get missing depe

Post by gerald_clark » 2009/08/28 13:10:25

Please do the required reading.
http://www.centos.org/modules/newbb/viewforum.php?forum=47

When you build your own packages, you resolve your own dependencies.
man yum
This should help you find some of the packages you need to install.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Trying to install courier-authlib* packages(get missing dependeny)

Post by pschaff » 2009/08/28 18:18:26

Might be as simple as using "yum localinstall ..." rather than using rpm and having yum resolve the dependencies. You may also want to read http://wiki.centos.org/HowTos/CreateLocalRepos

Post Reply

Return to “CentOS 4 - Software Support”