Error: lvm2 conflicts with lvm2-cluster < 2.02.42

Issues related to software problems
Post Reply
kilbasar
Posts: 3
Joined: 2010/01/25 18:27:55

Error: lvm2 conflicts with lvm2-cluster < 2.02.42

Post by kilbasar » 2010/01/25 18:49:22

Hi all. Long time listener, first time caller. I've got a case of Yum Conflict Fever, and could use some help sorting it out.

I've got a cluster of two CentOS 4.5 32bit servers, which are being used for mail purposes. I inherited these from another admin, and they have not been updated in a long time. I'd really like to get them up to date, but get stuck at a conflict:

[code]
[root@mail1 ~]# yum update
Loading "protectbase" plugin
Setting up Update Process
Setting up repositories
update 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 172 kB 00:00
update : ################################################## 538/538
Added 538 new packages, deleted 0 old in 2.77 seconds
primary.xml.gz 100% |=========================| 611 kB 00:00
base : ################################################## 1599/1599
Added 1599 new packages, deleted 0 old in 5.76 seconds
primary.xml.gz 100% |=========================| 190 B 00:00
Added 0 new packages, deleted 0 old in 0.00 seconds
primary.xml.gz 100% |=========================| 36 kB 00:00
extras : ################################################## 141/141
Added 141 new packages, deleted 0 old in 0.41 seconds
1 packages excluded due to repository protections
Resolving Dependencies
....
(downloading headers)
....
--> Running transaction check
--> Processing Conflict: lvm2 conflicts lvm2-cluster < 2.02.42
--> Finished Dependency Resolution
Error: lvm2 conflicts with lvm2-cluster < 2.02.42
[/code]

Could use some advice on how to resolve this. System info is:
[code]
[root@mail1 ~]# uname -a
Linux mail1 2.6.9-55.ELsmp #1 SMP Wed May 2 14:28:44 EDT 2007 i686 i686 i386 GNU/Linux
[root@mail1 ~]# cat /etc/redhat-release
CentOS release 4.5 (Final)
[/code]

Installed versions are:
[code]
[root@mail1 ~]# rpm -qa lvm2\*
lvm2-2.02.21-5.el4
lvm2-cluster-2.02.21-7.el4
[/code]

My googling led me to to the following forum thread and bug report:
[url=https://www.centos.org/modules/newbb/viewtopic.php?topic_id=17166]Dependency error lvm2 conflicts with lvm2-cluster on routine update[/url]
[url=http://bugs.centos.org/view.php?id=3809]0003809: CSGFS lvm2-cluster dependency problem[/url]

However, the summary of those seems to be that the problem was fixed with a newer version of the RPMs, so I'm not sure why I have this problem currently, or what I can do to fix it.

Thanks a lot!

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Error: lvm2 conflicts with lvm2-cluster < 2.02.42

Post by pschaff » 2010/01/25 18:59:53

Looks like you may not have the [url=http://wiki.centos.org/AdditionalResources/Repositories?highlight=(csgfs)]CS/GFS[/url] repo enabled to get the latest lvm2-cluster package.

kilbasar
Posts: 3
Joined: 2010/01/25 18:27:55

Re: Error: lvm2 conflicts with lvm2-cluster < 2.02.42

Post by kilbasar » 2010/01/25 19:13:23

Zounds! That sounds completely correct. I'll give that a go and see what happens. Thanks!

kilbasar
Posts: 3
Joined: 2010/01/25 18:27:55

Re: Error: lvm2 conflicts with lvm2-cluster < 2.02.42

Post by kilbasar » 2010/01/25 20:09:45

Somehow, that repository was indeed disabled. I enabled it, and now everything is fine. Going to cross my fingers and hope the update goes smoothly (I have horror stories of updating old Gentoo boxes, but RPMs tend to go smoother as long as all the dependencies work out).

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Error: lvm2 conflicts with lvm2-cluster < 2.02.42

Post by pschaff » 2010/01/25 20:20:38

Good luck - and update frequently. :-)

Post Reply

Return to “CentOS 4 - Software Support”