AllowPassword already on for nxserverI

Issues related to software problems
qwertyjjj
Posts: 40
Joined: 2009/12/26 14:18:33

AllowPassword already on for nxserverI

Postby qwertyjjj » 2010/07/21 17:29:28

I'm following the guide here: http://wiki.centos.org/HowTos/FreeNX

Specifically there is a part that says:
If your machine is connected to the Internet, you'll probably want to disallow ssh password authentication (which is advised but not mandatory). Edit the /etc/ssh/sshd_config file and change/add the following lines:
PasswordAuthentication no
AllowUsers nx
Don't forget to restart the sshd daemon after making that change:
service sshd restart


I already have PasswordAuthentication yes
in my file as I need it to login to the server through ssh.
Do I just skip that line and only add
AllowUsers nx mynxuser
at the end?

Also, I followed the rest of the manual and when I tried the client on Windows it failed:
I put in a user and password to login but shouldn't it be using the key instead? I think the problem is related to the above due to:

Code: Select all

NX> 203 NXSSH running with pid: 1428
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: xx.xxx.xxx.199 on port: 1057
NX> 211 The authenticity of host '[xx.xxx.xxx.199]:1057 ([xx.xxx.xxx.199]:1057)' can't be established.
RSA key fingerprint is e5:7b:4f:8d:89:5d:ec:4d:f7:d8:90:ba:4b:fb:53:8a.
Are you sure you want to continue connecting (yes/no)?
Warning: Permanently added '[xx.xxx.xxx.199]:1057' (RSA) to the list of known hosts.
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 3.2.0-73 OS (GPL, using backend: not detected)
NX> 105 hello NXCLIENT - Version 3.2.0
NX> 134 Accepted protocol: 3.2.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: jasonnxs
NX> 102 Password:
NX> 103 Welcome to: serverxx.xxx.xxx-198.live-servers.net user: jasonnxs
NX> 105 listsession --user="jasonnxs" --status="suspended,running" --geometry="1440x900x32+render" --type="unix-kde"
NX> 127 Sessions list of user 'jasonnxs' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: jasonnxs
NX> 105 startsession  --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" \
    --strict="0" --composite="1" --media="0" --session="Linux%20Desktop" --type="unix-kde" --geometry="1434x804" --client="winnt" \
    --keyboard="pc102/us" --screeninfo="1434x804x32+render"

ssh: connect to host 127.0.0.1 port 22: Connection refused
NX> 280 Exiting on signal: 15