USB Memory Stick/Pen-drive Not workin

Issues related to hardware problems
Post Reply
james007
Posts: 4
Joined: 2005/01/12 15:48:57

USB Memory Stick/Pen-drive Not workin

Post by james007 » 2005/04/15 09:41:10

im noob to this Linux stuff :-?

Wright i have just installed cent OS 4.0 and i am have in a bit of trouble wit set in up my (USB mem stick / pen-drive)
i put the pen drive in and it duz nut tin the light on it duz not even flash.

I have tried to ad-it as an icon on the desktop as a drive but it duz not list it in the menu.
How do i tell if the system is detecting the pen drive under this distu as I have try'd uthere distu's of Linux and it work's fine

plz can anyone tell me how to get my pen drive work in or suggestion's on what to look for plz :-D


Thanx James :-D

nevat
Posts: 30
Joined: 2005/04/06 10:28:29
Location: Barcelona (Spain)
Contact:

Re: USB Memory Stick/Pen-drive Not workin

Post by nevat » 2005/04/18 09:06:37

It's strange, I can mount my USB stick in my CentOS 4 without problems, when I plug the USB a hard drive icon appears in my desktop... the same with a Nikon camera.

Please, look if your USB stick (what's the manufacturer and model ?) supports "USB Mass Storage protocol", you can find this information in the box of the product (look for a logo or similar) or in the instructions manual (they should appear in "Speficiations").

james007
Posts: 4
Joined: 2005/01/12 15:48:57

Re: USB Memory Stick/Pen-drive Not workin

Post by james007 » 2005/04/20 13:50:21

Thanx for the reply nevat



How did you mount the pen drive? .... :-D


this is what i try'd from log'd in as root am i doin out wrong

(#modprobe usb-storage)... when i do this nutting happens no errors

(#mkdir/mnt/usbdrive)... when i do do this i check to see if the directory was made and it was

(#mount -t vfat /dev/sdal/mnt/usbdrive)... this duz nutting to no errors

when i have dun all of this i check the directory and the is nutting in it :-?


i can not find a model No... but here is all the info i can find about the pen drive


Silver Pearl Usb 2.0 128MB pen drive

OS supported me,2000, .net... linux 2.4.0


if you could help me with the info i have gave you i wud be most grateful...
:lol:

nevat
Posts: 30
Joined: 2005/04/06 10:28:29
Location: Barcelona (Spain)
Contact:

Re: USB Memory Stick/Pen-drive Not workin

Post by nevat » 2005/04/21 08:57:47

Here we go again :)

Next thing to check, plug your usb, open a terminal and run this command:

dmesg

Look the final lines if your system has detected that USB device has plugged.
If you don't know about this, paste this lines here.

james007
Posts: 4
Joined: 2005/01/12 15:48:57

Re: USB Memory Stick/Pen-drive Not workin

Post by james007 » 2005/04/21 14:31:06

here you go hope this can help you help me :-D


ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
PCI: Found IRQ 3 for device 0000:00:01.2
PCI: Sharing IRQ 3 with 0000:00:01.3
ohci_hcd 0000:00:01.2: OHCI Host Controller
ohci_hcd 0000:00:01.2: irq 3, pci mem cf818000
SELinux: initialized (dev usbdevfs, type usbdevfs), uses genfs_contexts
ohci_hcd 0000:00:01.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 3 ports detected
PCI: Found IRQ 3 for device 0000:00:01.3
PCI: Sharing IRQ 3 with 0000:00:01.2
ohci_hcd 0000:00:01.3: OHCI Host Controller
ohci_hcd 0000:00:01.3: irq 3, pci mem cf8dc000
ohci_hcd 0000:00:01.3: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
usb 1-1: new full speed USB device using address 2
ohci_hcd 0000:00:01.2: remove, state 1
usb usb1: USB disconnect, address 1
usb 1-1: USB disconnect, address 2
ohci_hcd 0000:00:01.2: USB bus 1 deregistered
ohci_hcd 0000:00:01.3: remove, state 1
usb usb2: USB disconnect, address 1
ohci_hcd 0000:00:01.3: USB bus 2 deregistered
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.1 (1919 buckets, 15352 max) - 356 bytes per conntrack
eth0: Media Link On 100mbps full-duplex
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
i2c /dev entries driver
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
lp0: using parport0 (polling).
lp0: console ready
SCSI subsystem initialized
Initializing USB Mass Storage driver... <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< look's like it can find it i think...
usbcore: registered new driver usb-storage <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< but how do i mount
USB Mass Storage support registered. <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< :-?
eth0: no IPv6 routers present


Thanx Navat

james007
Posts: 4
Joined: 2005/01/12 15:48:57

Re: USB Memory Stick/Pen-drive Not workin

Post by james007 » 2005/04/21 15:55:03

[quote]
nevat wrote:
Here we go again :)

Next thing to check, plug your usb, open a terminal and run this command:

dmesg

Look the final lines if your system has detected that USB device has plugged.
If you don't know about this, paste this lines here.[/quote]

ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
PCI: Found IRQ 3 for device 0000:00:01.2
PCI: Sharing IRQ 3 with 0000:00:01.3
ohci_hcd 0000:00:01.2: OHCI Host Controller
ohci_hcd 0000:00:01.2: irq 3, pci mem cf818000
SELinux: initialized (dev usbdevfs, type usbdevfs), uses genfs_contexts
ohci_hcd 0000:00:01.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 3 ports detected
PCI: Found IRQ 3 for device 0000:00:01.3
PCI: Sharing IRQ 3 with 0000:00:01.2
ohci_hcd 0000:00:01.3: OHCI Host Controller
ohci_hcd 0000:00:01.3: irq 3, pci mem cf8dc000
ohci_hcd 0000:00:01.3: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
usb 1-1: new full speed USB device using address 2
ohci_hcd 0000:00:01.2: remove, state 1
usb usb1: USB disconnect, address 1
usb 1-1: USB disconnect, address 2
ohci_hcd 0000:00:01.2: USB bus 1 deregistered
ohci_hcd 0000:00:01.3: remove, state 1
usb usb2: USB disconnect, address 1
ohci_hcd 0000:00:01.3: USB bus 2 deregistered
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.1 (1919 buckets, 15352 max) - 356 bytes per conntrack
eth0: Media Link On 100mbps full-duplex
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
i2c /dev entries driver
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
lp0: using parport0 (polling).
lp0: console ready
SCSI subsystem initialized
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
eth0: no IPv6 routers present

nevat
Posts: 30
Joined: 2005/04/06 10:28:29
Location: Barcelona (Spain)
Contact:

Re: USB Memory Stick/Pen-drive Not workin

Post by nevat » 2005/04/25 08:34:39

Your system detects correctly your USB, I don't know why don't automount the device.
Can you post your /etc/fstab file here ?

Post Reply

Return to “CentOS 4 - Hardware Support”