harddisk / hdparm performance trouble. knoppix vs centos

Issues related to hardware problems
XhonkX
Posts: 9
Joined: 2007/03/12 15:17:51

Re: harddisk / hdparm performance trouble. knoppix vs centos

Postby XhonkX » 2007/03/13 22:25:50

>The Knoppix may just be running a new kernel with some speed enhancements for your chipset. Wait a few days for CentOS 5 may help.

knoppix 3.7 is running linux kernel 2.4.27

>Verify that your system is realy "idle" when doing the test. Check current disk status via "sar -d" (from sysstats package) or something similar. Make sure >updatedb or anacron has not kicked in etc. You may resort to testing using the CentOS 4.4 rescue mode and test that way

from sysstat package thx

it is a Pentium III cpu MHz 451.818 with 512 MB ram and a standard installation without X
system idle 95% one user :-)

pjwelsh
Posts: 2570
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: harddisk / hdparm performance trouble. knoppix vs centos

Postby pjwelsh » 2007/03/14 02:30:08

Grab the CentOS 3.x CD/DVD and boot with "linux rescue" and run your test. That will be your 2.4 test. This may be one of the times that old kernel kernel with old hardware may be best. Try the CentOS 3.

abced123
Posts: 3
Joined: 2007/05/11 11:06:04

Re: harddisk / hdparm performance trouble. knoppix vs centos

Postby abced123 » 2007/05/11 11:26:51

Sorry to jump in this thread, but I have this irrelevant problem where I have exact drive as:
/dev/hdg:

Model=WDC WD1200JB-75CRA0, FwRev=16.06V16, SerialNo=WD-WMA8C2103804
Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
RawCHS=16383/16/63, TrkSize=57600, SectSize=600, ECCbytes=40
BuffType=DualPortCache, BuffSize=8192kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=234375000
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=no WriteCache=enabled
Drive conforms to: device does not report version:

* signifies the current active mode


but notice it report udma2

and my IDE controller is :

00:0f.0 Mass storage controller: Promise Technology, Inc. PDC20267 (FastTrak100/Ultra100) (rev 02)
Subsystem: Promise Technology, Inc. Ultra100
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at dc00 [size=8]
I/O ports at e000 [size=4]
I/O ports at e400 [size=8]
I/O ports at e800 [size=4]
I/O ports at ec00 [size=64]
Memory at d8000000 (32-bit, non-prefetchable) [size=128K]
Capabilities: [58] Power Management version 1


So, how to enable the drive to udma5 ?

Thanks

foxb
Posts: 1914
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: harddisk / hdparm performance trouble. knoppix vs centos

Postby foxb » 2007/05/11 13:49:49

From your post I do not see what is default mode...

read the man page of hdparm

Are you sure that you have correct cable?

In future just start new topic and note that is similar to another one.


Return to “CentOS 4 - Hardware Support”

Who is online

Users browsing this forum: No registered users and 1 guest