network down

Issues related to configuring your network
Post Reply
nspierbundel
Posts: 1
Joined: 2007/09/20 08:00:22

network down

Post by nspierbundel » 2007/09/20 08:24:50

We are running a centos 4.4 server 2.6.9-55.0.2.ELsmp

The configuration has 2 network cards.

one intel e1000 (dell poweredge 1800) integrated
one 3com card.

This machine runs samba, cups, squid, apache, mysql, pptp, clamav and all the usual stuff.

The intel card eth1 runs in a 192.xxx.xxx.xxx connected to a linksys router to the internet.
the 3com card eth0 runs in a 10.xxx.xxx.xxx network connected to a range of 3com switches.

Users are connected to the 3com card and can use squid auth. to connect to the internet

this morning for the 3th time this 2 months the network was unreachable.
At first the filesharing is getting slower and slower
internet is getting slower
a lot of connection errors with puty to the server also slow
and eventualy everything times out and no connection is possible any more.

The connection to the internet is strangely still working.

What I have tried.
1. Replaced all cables with new ones.
2. Replaced a switch with a new one.
3. Replaced network cards.
4. switched the networkcables from eth0 to eth1 and did a ifconfig to change the 192 adress to a 10 adress.
5. rebooted many times
6. moved the server to another room. (maybe a wallconnector broken ?)
7. runned antirootkit

none of the above seems to fix the problem. It looks like someone or something is triggering somethings
it happens twice at the end of the working day and today at the start. (or maybe unnoticed yesterday afternoon)

after a few reboots and restarting al the services (by a script :-D ) the users can work again :s

in my /var/log/messages I see a lot of these. (never been a real problem before i think)
smbd[5742]: tdb(/var/cache/samba/printing/HP_4100DTN.tdb): rec_read bad magic 0x29 at offset=22304
this happens on all the printers on the system.

Does anyone has an idea.

mine have run out.
thanks Daniel

yyagol
Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E
Contact:

network down

Post by yyagol » 2007/09/25 22:17:18

try to stop samba and delete this file
/var/cache/samba/printing/HP_4100DTN.tdb
then start samba again ( when the problem occurs ) , this files ar the tbd cache for printing
it is safe to remove them ( or just move it to a new location )

Post Reply

Return to “CentOS 4 - Networking Support”