Page 1 of 1

Resolver allways appends domain name to query

Posted: 2008/01/23 09:15:10
by daniel311
Hello CentOS/RHEL-Users,

I have configured my DNS server to resolve all subdomains of my local domain to the IP of my web server. This part works as expected. Nslookup subdomainxyz.mydomain.com returns the correct IP.

Now the problem is, that my proxy (Webwasher 6 CSM) routes all requests of unknown hosts to my web server too. If a user goes to "http://fjiwjewiu.fewhiofs.vhiuvew.fhzwi" the resolver of my CentOS 4 (glibc 2.3.4-2.36) always appends .mydomain.com and so the user is redirected to my web server for any site, that is unknown to the DNS e.g. misspelled URLs.

How can I disable this behaviour?

My /etc/resolv.conf has only a nameserver entry, nsswitch.conf has 'hosts: files dns' and my /etc/hosts looks like that:
127.0.0.1 localhost.localdomain localhost
IP_OF_MY_PROXY maydomain.com mydomain

If I run 'getent hosts anything-gkwlwifwhfslj.dmofw.fkewon' i get:
IP_OF_MY_WEBSERVER anything-gkwlwifwhfslj.dmofw.fkewon.mydomain.com

'nslookup anything-gkwlwifwhfslj.dmofw.fkewon' works as expected and can't find a matching ip.

Best regards,
Daniel311

Re: Resolver allways appends domain name to query

Posted: 2008/01/24 08:17:59
by daniel311
Now maybe I found the solution here... http://kbase.redhat.com/faq/FAQ_45_6371.shtm

There seems to be a problem with Webwasher and "getent hosts". They both seem to ignore the default or overridden option "options ndots:1" in /etc/resolv.conf.